Date created: Friday, June 6, 2014 10:13:44 AM. Last modified: Monday, February 29, 2016 10:37:34 AM

Basic PPPoA ADSL1/2+

Simple 1841 ISR 1st Gen ADSL config with WIC-1ADSL;

interface ATM0/0/0
 description PSTN: 1234567890
 no ip address
 atm vc-per-vp 128
 atm restart timer 300
 no atm ilmi-keepalive
 dsl operating-mode auto 
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 !
!
interface Dialer1
 ip address negotiated
 ip accounting output-packets
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 load-interval 30
 dialer pool 1
 dialer-group 1
 keepalive 2
 ppp authentication chap callin
 ppp chap hostname xxx@xxxx.xxx
 ppp chap password xxxx

Simple 1941 ISR 2nd Gen ADSL config with EHWIC-VA-DSL-M, IOS 15.3(3)M5 and firmware VA_A_39m_B_38h3_24h.bin

interface ATM0/1/0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
interface Dialer1
 description ISP
 bandwidth 870
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 no ip route-cache
 load-interval 30
 dialer pool 1
 dialer-group 1
 ntp disable
 ipv6 nd ra suppress all
 keepalive 2
 ppp authentication chap callin
 ppp chap hostname xxxxx
 ppp chap password 7 xxxxxxx
 ppp ipcp route default
 no cdp enable
 !
 ipv6 address dhcp rapid-commit
 ipv6 enable
 ipv6 nd prefix 11:22:33:01::1/64 ! Provider allocated routed /48
!
ipv6 route ::/0 Dialer1
!
int gi0/1
 description LAN
 ipv6 address 11:22:33:04::1/64
 ipv6 enable
 ipv6 nd other-config-flag

For ISRG2 887VA style routers;

interface ATM0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
interface Dialer1
 description Backup Link
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxx@xxx.xxx
 ppp chap password 0 xxxxxxx