Date created: Wednesday, September 9, 2015 11:20:51 AM. Last modified: Friday, August 10, 2018 3:44:36 PM

MST over L2TPv3

Recap on MST

References:
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3560/software/release/12-2_52_se/configuration/guide/3560scg/swmstp.html
http://packetlife.net/blog/2010/apr/26/multiple-spanning-tree-mst/

This example topology shows two end sites with dual provider CPEs and dual customer switches. CPE 1 and 3 have a layer 2 port-based xconnect between them (using L2TPv3) that transports VLAN headers and BPDUs and L2CPs (this is becasue it's port based and these are 1941's with xconnect on the built in layer 3 interfaces). CPE 2 and 4 also have the same tunnel, which completes a layer 2 loop so MST is running to close the link between SW4 and CPE4.

Side Note: HSRP was tested running on VLANs 10 and 20 over the stretched layer 2 infrastructure which worked fine.

2nd Side Note: UDLD is being passed (as would be expected using port based xconnect) using the interface config "udld port aggressive" on the switch ports between SW1 and SW3 and between SW2 and SW4.

 

This is a basic MST configuration, instance 0 is for layer 2 VLANs (10, 20) stretched over the WAN, instance 1 is for VLANs terminated locally (100, 200) and routed across the WAN.

! This is applied to all four switches:

spanning-tree mst configuration
 name Region1
 revision 1
 instance 1 vlan 100, 200
!
! By moving VLANs 100 and 200 into instance 1, that leaves VLANs 10 and 20 in instance 0 by default
!
spanning-tree mst hello-time 1
spanning-tree mst forward-time 4
spanning-tree mst max-age 6
!
vlan 10
 name L2-VLAN-10
!
vlan 20
 name L2-VLAN-20
!
vlan 100
 name L3-VLAN-100
!
vlan 200
 name L3-VLAN-200

interface GigabitEthernet0/1
 description L2 Trunk to 1941 Gi0/0
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface GigabitEthernet0/2
 description L2 Trunk to OtherSwitch Fa1/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20,100,200
 switchport mode trunk
!
interface GigabitEthernet0/3
 description L3 Trunk to 1941 Fa0/0/3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100,200
 switchport mode trunk

interface Vlan10
 ip address 192.168.10.2 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.2 255.255.255.0
!


Check that SW1 (the ME3750) is the root bridge in MST instance 0 for all switches (verifying that BPDUs are being passed over the L2TPv3 pseudowires):

! Note, the pseudowire from CPE1 to CPE3 is down at the time these captures are taken so the root ports at site 2 point towards the pseudowire between CPE2 and CPE4

SW1#show spanning-tree  mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
Root          this switch for the CIST
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.3    P2p
Fa1/0/2          Desg FWD 200000    128.4    P2p
Fa1/0/3          Desg FWD 200000    128.5    P2p Bound(PVST)


SW2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address 3c08.f67d.3600  priority      32768 (32768 sysid 0)
Root          address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
              port    Gi0/2           path cost     0
Regional Root address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/1            Desg FWD 20000     128.1    P2p
Gi0/2            Root FWD 200000    128.2    P2p
Gi0/3            Desg FWD 200000    128.3    P2p Bound(PVST)


SW3#show spanning-tree mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address 381c.1a5e.8e00  priority      32768 (32768 sysid 0)
Root          address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
              port    Gi1/0/2         path cost     0
Regional Root address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
                                      internal cost 240000    rem hops 17
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 20000     128.1    P2p
Gi1/0/2          Root FWD 20000     128.2    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p Bound(STP)


SW4#show spanning-tree mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address c47d.4fc1.bf08  priority      32768 (32768 sysid 0)
Root          address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
              port    Gi1/1           path cost     0
Regional Root address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
                                      internal cost 220000    rem hops 18
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/1            Root FWD 20000     128.1    P2p
Gi1/2            Desg FWD 20000     128.2    P2p
Gi1/3            Desg FWD 20000     128.3    P2p

 

Change SW4 to be the root bridge in MST instance 0 (again verifying that the BPDUs are traversing the L2TPv3 pseudowires):

! Note, the pseudowire from CPE1 to CPE3 is down at the time these captures are taken

SW4(config)#spanning-tree mst 0 priority 0


SW1#show spanning-tree  mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address 0025.46fd.ea00  priority      4096  (4096 sysid 0)
Root          address c47d.4fc1.bf08  priority      0     (0 sysid 0)
              port    Fa1/0/2         path cost     0
Regional Root address c47d.4fc1.bf08  priority      0     (0 sysid 0)
                                      internal cost 220000    rem hops 18
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.3    P2p
Fa1/0/2          Root FWD 200000    128.4    P2p
Fa1/0/3          Desg FWD 200000    128.5    P2p Bound(PVST)


SW2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address 3c08.f67d.3600  priority      32768 (32768 sysid 0)
Root          address c47d.4fc1.bf08  priority      0     (0 sysid 0)
              port    Gi0/1           path cost     0
Regional Root address c47d.4fc1.bf08  priority      0     (0 sysid 0)
                                      internal cost 20000     rem hops 19
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/1            Root FWD 20000     128.1    P2p
Gi0/2            Desg FWD 200000    128.2    P2p
Gi0/3            Desg FWD 200000    128.3    P2p Bound(PVST)


SW3#show spanning-tree mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address 381c.1a5e.8e00  priority      32768 (32768 sysid 0)
Root          address c47d.4fc1.bf08  priority      0     (0 sysid 0)
              port    Gi1/0/2         path cost     0
Regional Root address c47d.4fc1.bf08  priority      0     (0 sysid 0)
                                      internal cost 20000     rem hops 19
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 20000     128.1    P2p
Gi1/0/2          Root FWD 20000     128.2    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p Bound(STP)


SW4#show spanning-tree mst 0

##### MST0    vlans mapped:   1-99,101-199,201-4094
Bridge        address c47d.4fc1.bf08  priority      0     (0 sysid 0)
Root          this switch for the CIST
Operational   hello time 1 , forward delay 4 , max age 6 , txholdcount 6
Configured    hello time 1 , forward delay 4 , max age 6 , max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/1            Desg FWD 20000     128.1    P2p
Gi1/2            Desg FWD 20000     128.2    P2p
Gi1/3            Desg FWD 20000     128.3    P2p

 

Here the output of "show cdp neigbours" on SW4 (ME6524) shows SW3 (2960S) and SW2 (3560E) verifying that other L2CP frames are transported over the L2TPv3 pseudowires in addition to BPDUs:

ME6524#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
3560E            Gig 1/1           156             R S I  WS-C3560X Gig 0/1
2960S            Gig 1/2           127              S I   WS-C2960S Gig 1/0/2

 

Port based xconnects on 1941s/2921s/2951s (ISR G2s in general) using L2TPv3 will transport VLAN tags and BPDUs/L2CPs as shown. The MTU for the local switch facing interface Gi0/0 on each CPE router is not changed from the standard 1500. In classical IOS extra layer 2 headers like VLAN tags aren't counted when a frame comes in/out.

On the WAN facing interfaces, the Gi0/1's on each CPE where the pseudowires are routing across the WAN, the MTU is set to 1542. That accounts for 70 bytes of headers including the customer's layer 2 headers but excluding the layer 2 headers of the WAN CPEs themselves, as follows:

Total bytes on the wire between CPEs when pinging from SW2 (192.168.20.2) to SW4 (192.168.20.4) is 1560 bytes:
  14 bytes Ethernet header between CPE WAN interfaces
+ 4 byte VLAN tag and ethertype between CPE WAN interfaces (VLAN 300 in this example which is hex 012C, CoS 0)
+ 20 bytes IP header between WAN CPEs (192.168.30.2 to 192.168.30.4 in this example)
+ 4 bytes L2TP header between WAN CPEs
+ 14 bytes Ethernet headers between end site switches (SW2 and SW4)
+ 4 bytes VLAN and ethertype between end site switches (VLAN 20 in this example, hex 14, Cos 0)
+ 20 bytes IP header between end site switches (192.168.20.2 to 192.168.20.4)
+ 8 bytes ICMP header between end site switches
+ 1472 bytes ICMP payload between end site switches (they are configured with MTU 1500, so they -20 bytes IP header and 8 bytes ICMP header)

Adding all those headers captured "on the wire" between CPEs gives 88 bytes of headers total, but the first 18 bytes are the layer 2 headers of the WAN CPEs themselves. As per above classical IOS doesn't count this in the interface MTU configuration so of the 1560 bytes on the wire, 1560-18 = 1542, is the required MTU size for the WAN facing interface Gi0/1 on each CPE.

Another way of calculating this; For this example customer wanting to send 1500 bytes of layer 2 payload, the CPEs must also include an extra 18b ytes for the customer's layer 2 headers and 20 bytes of IP and 4 bytes of L2TP headers for WAN transport, making a total of 1542 bytes.


This is the output of a packet capture on CPE4 when pinging from SW2 (MAC 3c08.f67d.3643, 192.168.20.2 in hex C0A81402) to SW4 (MAC c47d.4fc1.bf08, 192.168.20.4 in hex C0A81404) which is passed over the pseudowire between CPE2 (MAC 442b.0375.46a1, 192.168.30.2 in hex C0A81E02) and CPE4 (MAC a80c.0de2.4011, 192.168.30.4 in hex C0A81E04) as the pseudowire between CPE1 and CPE3 was down at the time of capture):


2951-4#monitor capture buffer cb size 1024 max-size 2000
2951-4#monitor capture point ip cef cpc gi0/1 both
2951-4#monitor capture point associate cpc cb
2951-4#monitor capture point start cpc

SW2#show ip arp vlan 20
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.20.4            0   c47d.4fc1.bf08  ARPA   Vlan20
Internet  192.168.20.1            0   0025.46fd.ea41  ARPA   Vlan20
Internet  192.168.20.2            -   3c08.f67d.3643  ARPA   Vlan20
Internet  192.168.20.3           71   381c.1a5e.8e42  ARPA   Vlan20

SW2#ping 192.168.20.4 repeat 1 df-bit size 1500

Type escape sequence to abort.
Sending 1, 1500-byte ICMP Echos to 192.168.20.4, timeout is 2 seconds:
Packet sent with the DF bit set
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 8/8/8 ms


1941-2#show ip arp GigabitEthernet 0/1.300
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.30.2            -   442b.0375.46a1  ARPA   GigabitEthernet0/1.300
Internet  192.168.30.4          192   a80c.0de2.4011  ARPA   GigabitEthernet0/1.300


2951-4#monitor capture point stop cpc
2951-4#show monitor capture buffer cb dump

15:57:01.953 UTC Sep 10 2015 : IPv4 LES CEF    : Gi0/1.300 None

022ECA70:                   A80C0DE2 4011442B          (..b@.D+
022ECA80: 037546A1 8100012C 08004500 0606E322  .uF!...,..E...c"
022ECA90: 0000FE73 160BC0A8 1E02C0A8 1E04BF40  ..~s..@(..@(..?@
022ECAA0: 48CEC47D 4FC1BF08 3C08F67D 36438100  HN8..^.B<.v}6C..
022ECAB0: 00140800 450005DC 0FC94000 FF01BD01  ....E..\.I@...=.
022ECAC0: C0A81402 C0A81404 0800801E 00150000  @(..@(..........
022ECAD0: 00000000 00223793 ABCDABCD ABCDABCD  ....."7.+M+M+M+M
022ECAE0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECAF0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB30: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB40: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB50: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB60: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB70: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB80: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECB90: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECBA0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECBB0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECBC0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECBD0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECBE0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECBF0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC30: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC40: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC50: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC60: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC70: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC80: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECC90: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECCA0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECCB0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECCC0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECCD0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECCE0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECCF0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD30: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD40: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD50: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD60: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD70: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD80: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECD90: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECDA0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECDB0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECDC0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECDD0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECDE0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECDF0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE30: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE40: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE50: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE60: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE70: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE80: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECE90: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECEA0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECEB0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECEC0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECED0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECEE0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECEF0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF00: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF10: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF20: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF30: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF40: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF50: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF60: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF70: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF80: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECF90: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECFA0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECFB0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECFC0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECFD0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECFE0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ECFF0: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED000: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED010: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED020: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED030: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED040: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED050: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED060: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED070: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED080: ABCDABCD ABCDABCD ABCDABCD ABCDABCD  +M+M+M+M+M+M+M+M
022ED090: 00                                   .
! This last null byte on the end is a dummy/padding byte

14 bytes Ethernet header between WAN CPE interfaces
A80C0DE24011 442B037546A1 8100

4 byte VLAN tag and ethertype between WAN CPE interfaces
012C 0800

20 bytes IP header between WAN CPEs
45000606 E3220000 FE73160B C0A81E02 C0A81E04

4 bytes L2TP header between WAN CPEs
BF4048CE

14 bytes Ethernet headers between end site switches
C47D4FC1BF08 3C08F67D3643 8100 

4 bytes VLAN and ethertype between end site switches
0014 0800

20 bytes IP header between end site switches
450005DC 0FC94000 FF01BD01 C0A81402 C0A81404

8 bytes ICMP header between end site switches
0800801E 00150000

The rest is payload.

This is the config on the ISR-G2 CPEs (1941-2 in this case):

no spanning-tree vlan 100
no spanning-tree vlan 200

vlan 100
 name L3-VLAN-100

vlan 200
 name L3-VLAN-200


pseudowire-class L2TPv3
 encapsulation l2tpv3
 ip local interface GigabitEthernet0/1.300


interface GigabitEthernet0/0
 description xconnect to SW2 (3560E) Gi0/1
 no ip address
 duplex auto
 speed auto
 xconnect 192.168.30.4 456 encapsulation l2tpv3 pw-class L2TPv3

interface GigabitEthernet0/1
 description Link to WAN
 mtu 1542
 no ip address

interface GigabitEthernet0/1.300
 description /24 between WAN CPEs
 encapsulation dot1Q 300
 ip address 192.168.30.2 255.255.255.0

interface FastEthernet0/0/3
 description L3 Trunk to SW2 (3560E) Gi0/3
 switchport trunk allowed vlan 1,100,200,1002-1005
 switchport mode trunk
 no ip address

interface Vlan100
 description Routed Subnet 100
 ip address 192.168.101.252 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
standby 100 ip 192.168.101.254 standby 100 priority 254 standby 100 preempt interface Vlan200 description Routed Subnet 200 ip address 192.168.201.252 255.255.255.0 no ip redirects no ip unreachables no ip proxy-arp
standby 200 ip 192.168.201.254 standby 200 priority 254 standby 200 preempt 1941-2#show xconnect all detail Legend: XC ST=Xconnect State S1=Segment1 State S2=Segment2 State UP=Up DN=Down AD=Admin Down IA=Inactive SB=Standby HS=Hot Standby RV=Recovering NH=No Hardware XC ST Segment 1 S1 Segment 2 S2 ------+---------------------------------+--+---------------------------------+-- UP pri ac Gi0/0:3(Ethernet) UP l2tp 192.168.30.4:456 UP Interworking: none Session ID: 960363062 Tunnel ID: 3540866178 Protocol State: UP Remote Circuit State: UP pw-class: L2TPv3