Date created: Wednesday, December 7, 2016 10:45:38 AM. Last modified: Wednesday, December 7, 2016 10:45:38 AM

6500/7600 MUX UNI

References:
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/15-0SY/configuration/guide/15_0_sy_swcg/mpls.html#pgfId-1430355
http://networkengineering.stackexchange.com/questions/5774/cisco-7600-mux-uni-on-sre-ios

7600 PFC-3C example. The Layer 3 interfaces must be moved to SVI to support layer 3 tagged VLANs and tagged EoMPLS on the same physical interface:

interface GigabitEthernet8/1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 556 ! Only list VLANs which will be terminated at layer 3 on an SVI
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet8/1.123
 ! Configure PW-ID 1026 on Vlan 920, note that vlan-920 is *not* explicitly trunked on Gi8/1
 encapsulation dot1q 920
 xconnect 172.16.25.25 1026 encapsulation mpls
  mtu 1500
!
interface Vlan556
 ! Layer 3 sub-interface is moved to SVI
 no shutdown
 ip address 192.0.2.254

6500 PFC-3B Example. Due to the global scope of VLANs within the 6500/7600 platforms two seperate physical interfaces can not have a sub-interface with the same tagged VLAN ID:

interface GigabitEthernet4/1.100
 encapsulation dot1q 100
 ip address 192.0.4.1 255.255.255.0

interface GigabitEthernet5/1.100
 encapsulation dot1q 100
 ip address 192.0.5.1 255.255.255.0

! ^ This will not work, VLAN 100 was assigned to Gi4/1.100 first.

! To ensure a VLAN is not used somewhere before one tries to configure it:
no vlan 100
show vlan internal usage  | i 100