Date created: Tuesday, September 2, 2014 5:08:23 PM. Last modified: Thursday, November 11, 2021 10:16:38 AM

Pseudowire - Basic Backup Pseudowire

Test machines T1 and T2 are on the same IP subnet and connected to their relivant CPEs. The LAN interfaces on each CPE is a bridge group to a VLAN on the WAN (3-way bridge on CPE1). The PEs operate the redundant pseudowire feature (over MPLS) between the dual access-circuits at PE1 and single AC at PE2.

This basic setup has no BFD checking and it's a Y shape AC redundancy topology (SPoF).

c7200-adventerprisek9-mz.152-4.S5

! PE1
!
pseudowire-class mpls-class
 encapsulation mpls
 interworking ethernet
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 xconnect 10.0.0.2 12345 encapsulation mpls pw-class mpls-class
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 xconnect 10.0.0.2 67890 encapsulation mpls pw-class mpls-class

! PE2
!
pseudowire-class mpls-class
 encapsulation mpls
 interworking ethernet
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 xconnect 10.0.0.1 12345 encapsulation mpls pw-class mpls-class
  backup peer 10.0.0.1 67890 pw-class mpls-class
  backup delay 5 never

! CPE1
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 bridge-group 20
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 bridge-group 20
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 bridge-group 20
!
interface BVI20
 no ip address
!
bridge 20 protocol ieee
bridge 20 route ip

! T1
!
interface FastEthernet0/0
 ip address 192.168.5.4 255.255.255.0

PE1 and PE2 agree on PWE3 status;

PE1#show xconnect all detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Fa0/0.20:20(Eth VLAN)        UP mpls 10.0.0.2:12345               UP
            Interworking: ethernet               Local VC label 19
                                                 Remote VC label 20
                                                 pw-class: mpls-class
SB pri   ac Fa0/1.20:20(Eth VLAN)        UP mpls 10.0.0.2:67890               SB
            Interworking: ethernet               Local VC label 21
                                                 Remote VC label 21
                                                 pw-class: mpls-class
PE2#show xconnect all detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Fa0/0.20:20(Eth VLAN)        UP mpls 10.0.0.1:12345               UP
            Interworking: ethernet               Local VC label 20
                                                 Remote VC label 19
                                                 pw-class: mpls-class
IA sec   ac Fa0/0.20:20(Eth VLAN)        UP mpls 10.0.0.1:67890               SB
            Interworking: ethernet               Local VC label 21
                                                 Remote VC label 21
                                                 pw-class: mpls-class

When pinging from T1 to T2 both CPEs can see both test machine MACs

T1#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.5.4             -   ca01.0c4c.0008  ARPA   FastEthernet0/0
Internet  192.168.5.5             7   ca02.0c4c.0008  ARPA   FastEthernet0/0
CPE1#show bridge 20 verbose

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

BG Hash      Address      Action  Interface      VC    Age   RX count   TX count
20 08/0   ca02.0c4c.0008 forward  Fa0/0.20        -      0        266        289
20 08/1   ca01.0c4c.0008 forward  FastEthernet1/0 -      0        291        264

Flood ports                  RX count    TX count
FastEthernet0/0.20                  1           1
FastEthernet0/1.20                  0           2
FastEthernet1/0                     1           1
T2#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.5.4             7   ca01.0c4c.0008  ARPA   FastEthernet0/0
Internet  192.168.5.5             -   ca02.0c4c.0008  ARPA   FastEthernet0/0
CPE2#show bridge 20 verbose

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

BG Hash      Address      Action  Interface      VC    Age   RX count   TX count
20 08/0   ca02.0c4c.0008 forward  FastEthernet1/0 -      2          1          0
20 08/1   ca01.0c4c.0008 forward  Fa0/0.20        -      2          1          0

Flood ports                  RX count    TX count
FastEthernet0/0.20                  1           1
FastEthernet1/0                     1           1

Shutdown of primary AC on PE1 (fa0/0.20) causes the backup (fa0/1.20) to automatically become active

PE1#conf t
PE1(config)#int fa0/0.20
PE1(config-subif)#shut

PE1#show xconnect all detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
AD pri   ac Fa0/0.20:20(Eth VLAN)        AD mpls 10.0.0.2:12345               DN
            Interworking: ethernet               Local VC label unassigned
                                                 Remote VC label 20
                                                 pw-class: mpls-class
SB pri   ac Fa0/1.20:20(Eth VLAN)        UP mpls 10.0.0.2:67890               SB
            Interworking: ethernet               Local VC label 21
                                                 Remote VC label 21
                                                 pw-class: mpls-class

PE1#show xconnect all detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
AD pri   ac Fa0/0.20:20(Eth VLAN)        AD mpls 10.0.0.2:12345               DN
            Interworking: ethernet               Local VC label unassigned
                                                 Remote VC label 20
                                                 pw-class: mpls-class
UP pri   ac Fa0/1.20:20(Eth VLAN)        UP mpls 10.0.0.2:67890               UP
            Interworking: ethernet               Local VC label 21
                                                 Remote VC label 21
                                                 pw-class: mpls-class
PE2#show xconnect all detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
IA pri   ac Fa0/0.20:20(Eth VLAN)        UP mpls 10.0.0.1:12345               DN
            Interworking: ethernet               Local VC label 20
                                                 Remote VC label unassigned
                                                 pw-class: mpls-class
UP sec   ac Fa0/0.20:20(Eth VLAN)        UP mpls 10.0.0.1:67890               UP
            Interworking: ethernet               Local VC label 21
                                                 Remote VC label 21
                                                 pw-class: mpls-class

CPE re-learns the MAC on bridge 20 via the alternate WAN access port (fa0/1.20) and connectivity continues

CPE1#show bridge 20 verbose

Total of 300 station blocks, 298 free
Codes: P - permanent, S - self

BG Hash      Address      Action  Interface      VC    Age   RX count   TX count
20 08/0   ca02.0c4c.0008 forward  Fa0/1.20        -      1          1          0
20 08/1   ca01.0c4c.0008 forward  FastEthernet1/0 -      4          1          0

Flood ports                  RX count    TX count
FastEthernet0/0.20                  1           6
FastEthernet0/1.20                  2           5
FastEthernet1/0                     4           3