Basic dynamic to static routing failover (BGP to Route-map)

Topology

GNS3 Topology

Failover from main Ethernet circuit to customer edge to PE1, to dual DSL lines to LNS1 and LNS2. Two local subnets, one to represent a priority traffic source such as a voice VLAN (10.0.0.0/30). When the main Ethernet circuit is down traffic is balanced over the two DSL backup lines using a route map rather than static routes. This way the config stays simple with just default 0/0 routes everywhere on the CPE, no need to add/edit/rem0ve subnets at a later date

CE

ip sla monitor 1
 type echo protocol ipIcmpEcho 10.0.13.2 source-interface Ethernet0/3
 frequency 30
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
 type echo protocol ipIcmpEcho 10.0.11.2 source-interface Ethernet0/1
 frequency 30
ip sla monitor schedule 2 life forever start-time now
ip sla monitor 3
 type echo protocol ipIcmpEcho 10.0.12.2 source-interface Ethernet0/2
 frequency 30
ip sla monitor schedule 3 life forever start-time now
!
track 1 rtr 1 reachability
 delay down 20 up 20
!
track 2 rtr 2 reachability
 delay down 20 up 20
!
track 3 rtr 3 reachability
 delay down 20 up 20
! 
interface Ethernet0/0
 ip address 10.0.0.1 255.255.255.252
 ip policy route-map RM-FAIL-OVER
 full-duplex
!
interface Ethernet0/1
 ip address 10.0.11.1 255.255.255.252
 full-duplex
!
interface Ethernet0/2
 ip address 10.0.12.1 255.255.255.252
 full-duplex
!
interface Ethernet0/3
 ip address 10.0.13.1 255.255.255.252
 full-duplex
!
interface FastEthernet1/0
 ip address 10.0.0.5 255.255.255.252
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.0.0.0 mask 255.255.255.252
 network 10.0.0.4 mask 255.255.255.252
 neighbor 10.0.13.2 remote-as 200
 neighbor 10.0.13.2 soft-reconfiguration inbound
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 Ethernet0/1 220 track 2
ip route 0.0.0.0 0.0.0.0 Ethernet0/2 210 track 3
!
route-map RM-FAIL-OVER permit 10
 match interface Ethernet0/0
 set ip next-hop verify-availability 10.0.13.2 10 track 1
 set ip next-hop verify-availability 10.0.11.2 20 track 2
 set ip next-hop verify-availability 10.0.12.2 30 track 3