Date created: 03/03/16 21:02:56. Last modified: 04/06/18 17:15:14

Explicit Path for Pseudowires (IOS)

Example of how to define an explicit path for a pseudowire between two PE nodes in IOS. In this example an explicit path between two seperate PEs is created that differs from the IGP shortest path, the pseudowire will use the path and fall back to IGP shortest path:

mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup
mpls traffic-eng reoptimize timers frequency 60
mpls traffic-eng reoptimize timers delay installation 60
!
pseudowire-class PWE3-Static-L2-LSP
!
 encapsulation mpls
 preferred-path interface Tunnel100 disable-fallback
!
interface gigabitethernet0/0/0
 xconnect 10.0.0.2 101 pw-class PWE3-Static-L2-LSP
!
interface Tunnel100
 ip unnumbered Loopback0
 tunnel destination 10.0.0.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 1500
 tunnel mpls traffic-eng path-option 1 explicit name PE1-to-PE2
 tunnel mpls traffic-eng path-option 2 dynamic
!
ip explicit-path name PE1-to-PE2 enable
 next-address 10.0.1.2
 next-address 10.0.1.6
 next-address 10.0.0.2

Example 2: Xconnect a specific bridge domain/VFI through a specific LSP path using a static MPLS-TE tunnel, don't fall back to any other interface for the xconnect for LSP for the MPLS-TE path, this means that when this explicit LSP is down, the pseudowire is down:

!ME3600X
ip explicit-path name pe2_to_pe1_via_p1 enable
 next-address 10.10.0.22
 next-address 10.10.0.21
 next-address 10.10.0.65
 next-address 10.10.0.66
 exit

interface Tunnel1119
 description MPLS-TE Explicit path to pseudowire egress PE
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.0.0.1
 tunnel mpls traffic-eng path-option 1 explicit name pe2_to_pe1_via_p1
 exit

interface GigabitEthernet0/21
 description Local AC for pseudowire
 switchport trunk allowed vlan none
 switchport mode trunk
 service instance 200 ethernet
  encapsulation dot1q 200
  rewrite ingress tag pop 1 symmetric
  l2protocol forward
  bridge-domain 200
  exit
 exit

pseudowire-class PWE3_Force_Tu1119
 encapsulation mpls
 preferred-path interface Tunnel1119 disable-fallback
 exit

l2 vfi VLAN-200 manual
 vpn id 200
 neighbor 10.0.0.1 200 pw-class PWE3_Force_Tu1119
 exit

interface Vlan200
 xconnect vfi VLAN-200
 exit



!ASR920
ip explicit-path name pe1_to_pe2_via_p1 enable
 next-address 10.10.0.66
 next-address 10.10.0.65
 next-address 10.10.0.21
 next-address 10.10.0.22
 exit

interface Tunnel1119
 description MPLS-TE Explicit path to pseudowire egress PE
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.0.0.2
 tunnel mpls traffic-eng path-option 1 explicit name pe1_to_pe2_via_p1
 exit

interface GigabitEthernet0/0/0
 description Local AC for pseudowire
 no ip address
 negotiation auto
 cdp enable
 service instance 200 ethernet
  encapsulation dot1q 200
  rewrite ingress tag pop 1 symmetric
  l2protocol forward
  bridge-domain 200
  exit
 exit

pseudowire-class PWE3_Force_Tu1119
 encapsulation mpls
 preferred-path interface Tunnel1119 disable-fallback
 exit

l2 vfi VLAN-200 manual
 vpn id 200
 bridge-domain 200
 neighbor 10.0.0.2 20 encps mpls
 exit

interface BDI 200
 ip address x.x.x.x
 exit