Date created: Sunday, April 14, 2013 5:24:29 PM. Last modified: Wednesday, September 27, 2017 3:44:15 PM

Per Flow Load-Balancing Without FAT

Per-packet style load balancing can only be achieved using the interface sub-command "ip load-sharing per-packet" if MPLS FAT labels aren't supported (or Entropy labels with ELI). This example without FAT labels balances all traffic there for between P1 and P2 over the ECMPs but the PEs (edge LSRs) have no control over that so its not much good:

References:
https://sites.google.com/site/amitsciscozone/home/important-tips/mpls-wiki/fat-and-entropy-labels
http://www.cisco.com/en/US/docs/ios-xml/ios/mp_l2_vpns/configuration/12-2sy/mp-l2-vpns-12-2sy-book.pdf
http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/l2vpn_advanced_vpls.pdf

P1:

interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 description Link to PE1 f0/0
 ip address 10.255.1.1 255.255.255.252
 ip ospf 65000 area 0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.0.0.16 255.255.255.254
 ip load-sharing per-packet
 ip ospf 65000 area 0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/1
 ip address 10.0.0.18 255.255.255.254
 ip load-sharing per-packet
 ip ospf 65000 area 0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet2/0
 ip address 10.0.0.20 255.255.255.254
 ip load-sharing per-packet
 ip ospf 65000 area 0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet2/1
 ip address 10.0.0.22 255.255.255.254
 ip load-sharing per-packet
 ip ospf 65000 area 0
 duplex auto
 speed auto
 mpls ip
!
router ospf 65000
 log-adjacency-changes

PE1:

pseudowire-class MPWC
 encapsulation mpls
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 description link to P1 f0/0
 ip address 10.255.1.2 255.255.255.252
 ip ospf 65000 area 0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 description Link to CE1 f0/1
 no ip address
 duplex auto
 speed auto
 xconnect 10.0.2.1 5555 pw-class MPWC
!
router ospf 65000
 log-adjacency-changes