Date created: Wednesday, January 13, 2016 10:36:10 AM. Last modified: Monday, November 13, 2017 4:58:54 PM

Inter-AS MPLS OptionB Example

Example Inter-AS MPLS Option B eBGP configuration

# Configure internal iBGP facing interface and routing
set interfaces ge-0/0/2 unit 0 description "iBGP facing Link"
set interfaces ge-0/0/2 unit 0 family inet address 10.10.0.1/30
set interfaces ge-0/0/2 unit 0 family mpls
set protocols mpls interface ge-0/0/2.0

set interfaces lo0 unit 0 description "Core Loopback"
set interfaces lo0 unit 0 family inet address 10.0.0.1/32
set interfaces lo0 unit 0 family mpls

set routing-options router-id 10.0.0.1
set routing-options autonomous-system 10

set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
set protocols ospf area 0.0.0.0 interface lo0.0

set protocols ldp interface ge-0/0/2.0
set protocols ldp interface lo0.0

set protocols bgp group MP-iBGP description "MP-IBGP Peers"
set protocols bgp group MP-iBGP type internal
set protocols bgp group MP-iBGP local-address 10.0.0.1
set protocols bgp group MP-iBGP family inet-vpn unicast
set protocols bgp group MP-iBGP export next-hop-self

set policy-statement next-hop-self then next-hop self


# Configured external MP-BGP facing interface and routing
set protocols bgp group Inter-AS-OptB description "Inter-AS MPLS Option B"
set protocols bgp group Inter-AS-OptB type external
set protocols bgp group Inter-AS-OptB family inet-vpn unicast
set protocols bgp group Inter-AS-OptB import MP-eBGP-RT-Filter-Import
set protocols bgp group Inter-AS-OptB export MP-eBGP-RT-Filter-Export
set protocols bgp group Inter-AS-OptB neighbor 192.168.0.2 peer-as 20

set interfaces ge-0/0/1 unit 0 description "Link to external AS"
set interfaces ge-0/0/1 unit 0 family inet address 192.0.2.1/30
set interfaces ge-0/0/1 unit 0 family mpls
set protocols mpls interface ge-0/0/1.0

set  community Cust1_VPN1 members target:100:1
set  community Cust1_VPN2 members target:100:2
set  community Cust2_VPN1 members target:200:1

set policy-options policy-statement MP-eBGP-RT-Filter-Export term VPN1 from community [ Cust1_VPN1 Cust1_VPN2 Cust2_VPN1 ]
set policy-options policy-statement MP-eBGP-RT-Filter-Export term VPN1 then accept
set policy-options policy-statement MP-eBGP-RT-Filter-Export term Reject-All then reject

set policy-options policy-statement MP-eBGP-RT-Filter-Import term VPN1 from community [ Cust1_VPN1 Cust1_VPN2 Cust2_VPN1 ]