Inter-AS MPLS PW Stitching (labeled-unicast without LDP)

Topology

GNS3 Topology: Inter-AS MPLS Pseudowire between two CPEs using MPLS only, no multi-protocol BGP or VRF's. PE/ASBR routers are 7200 with image c7200-advipservicesk9-mz.122-33.SRE.

All the magic is really happening on the AS boarder routers. Under the BGP configuration for the BGP peering 'neighbor 198.15.0.2 send-label' enabled the distribution of MPLS labels with routes over the EBGP peering. On the interfaces facing each other of the two ASBR's the interface configuration command 'mpls bgp forwarding' enables MPLS frames to be sent and received on an interface that isn't running LDP or RSVP (instead using BGP for the MPLS signalling).

AS100ASBR

pseudowire-class PSWC
 encapsulation mpls
!
l2 vfi INTER-AS-PSW point-to-point
 neighbor 10.0.2.2 300 pw-class PSWC
 neighbor 10.0.1.1 100 pw-class PSWC
!
interface Loopback0
 ip address 10.0.1.2 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 198.15.0.1 255.255.255.0
 speed auto
 duplex auto
 mpls bgp forwarding
!
interface FastEthernet0/1
 ip address 10.0.100.2 255.255.255.0
 ip router isis 
 speed auto
 duplex auto
 mpls ip
!
router isis
 net 49.0100.0000.0000.0000.0002.00
 is-type level-2-only
 metric-style wide
 log-adjacency-changes
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.0.1.2 mask 255.255.255.255
 neighbor 198.15.0.2 remote-as 200
 neighbor 198.15.0.2 soft-reconfiguration inbound
 neighbor 198.15.0.2 send-label
 no auto-summary

AS200ASBR

pseudowire-class PSWC
 encapsulation mpls
!
l2 vfi INTER-AS-PSW point-to-point
 neighbor 10.0.2.1 200 pw-class PSWC
 neighbor 10.0.1.2 300 pw-class PSWC
!
interface Loopback0
 ip address 10.0.2.2 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 198.15.0.2 255.255.255.0
 speed auto
 duplex auto
 mpls bgp forwarding
!
interface FastEthernet0/1
 ip address 10.0.200.2 255.255.255.0
 ip router isis 
 speed auto
 duplex auto
 mpls ip
!
router isis
 net 49.0200.0000.0000.0000.0002.00
 is-type level-2-only
 metric-style wide
 log-adjacency-changes
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 10.0.2.2 mask 255.255.255.255
 neighbor 198.15.0.1 remote-as 100
 neighbor 198.15.0.1 soft-reconfiguration inbound
 neighbor 198.15.0.1 send-label
 no auto-summary

AS100PE1

pseudowire-class PSWC
 encapsulation mpls
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 no ip address
 speed auto
 duplex auto
 no keepalive
 xconnect 10.0.1.2 100 pw-class PSWC
!
interface FastEthernet0/1
 ip address 10.0.100.1 255.255.255.0
 ip router isis 
 speed auto
 duplex auto
 mpls ip
!
router isis
 net 49.0100.0000.0000.0000.0001.00
 is-type level-2-only
 metric-style wide
 log-adjacency-changes

AS200PE1

pseudowire-class PSWC
 encapsulation mpls
!
interface Loopback0
 ip address 10.0.2.1 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 no ip address
 speed auto
 duplex auto
 no keepalive
 xconnect 10.0.2.2 200 pw-class PSWC
!
interface FastEthernet0/1
 ip address 10.0.200.1 255.255.255.0
 ip router isis 
 speed auto
 duplex auto
 mpls ip
!
router isis
 net 49.0200.0000.0000.0000.0001.00
 is-type level-2-only
 metric-style wide
 log-adjacency-changes

CE1

interface FastEthernet0
 ip address 192.168.0.100 255.255.255.0
 speed auto

CE2

interface FastEthernet0
 ip address 192.168.0.200 255.255.255.0
 speed auto

Previous page: L2 VFI Examples
Next page: MPLS over PHY vs EFF+BDI/SVI