L2 VFI Examples

Example 1: Xconnect to an ME3600X/ME3800X into a VLAN/Bridge-domain

vlan 200
 exit

bridge-domain 200
 exit

interface GigabitEthernet0/2
 switchport trunk allowed vlan none
 switchport mode trunk
 service instance 200 ethernet
  encapsulation dot1q 2001
  rewrite ingress tag pop 1 symmetric
  bridge-domain 200
  exit
exit

l2vpn vfi context 200
 vpn id 200
 member 1.1.1.1 encapsulation mpls
 exit

interface Vlan200
 no ip address
 member vfi 200
 exit

VFI-TEST-PE#show bridge-domain 200
Bridge-domain 200 (1 ports in all)
State: UP                    Mac learning: Enabled
Maximum address limit: 10000
    GigabitEthernet0/2 service instance 200


VFI-TEST-PE#show xconnect all
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
DN pri  vfi 200                          UP mpls 1.1.1.1:200                  DN
UP pri   ac Vl200:200(Eth VLAN)          UP  vfi 200                          UP


VFI-TEST-PE#show l2vpn vfi name 200
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: 200, state: up, type: multipoint, signaling: LDP
  VPN ID: 200
  Local attachment circuits:
    Vlan200
  Pseudo-port interface: pseudowire100004
  Interface          Peer Address     VC ID        S
  pseudowire100005   1.1.1.1          200          Y

Example 2: Xconnect a specific bridge domain/VFI through a specific LSP path using a static MPLS-TE tunnel:

!ME3600X
interface GigabitEthernet0/21
 description xxxxxx
 switchport trunk allowed vlan none
 switchport mode trunk
 service instance 200 ethernet
  encapsulation dot1q 200
  rewrite ingress tag pop 1 symmetric
  l2protocol forward
  bridge-domain 200
  exit
 exit
!
l2 vfi VLAN-200 manual
 vpn id 200
 neighbor 10.0.0.1 200 encaps mpls
 exit
!
interface Vlan200
 xconnect vfi VLAN-200
 ip address x.x.x.x
 exit

!ASR920
interface GigabitEthernet0/0/0
 description xxx
 no ip address
 negotiation auto
 cdp enable
 service instance 200 ethernet
  encapsulation dot1q 200
  rewrite ingress tag pop 1 symmetric
  l2protocol forward
  bridge-domain 200
  exit
 exit
!
l2 vfi VLAN-200 manual
 vpn id 200
 bridge-domain 200
 neighbor 10.0.0.2 20 encps mpls
 exit
!
interface BDI 200
 ip address x.x.x.x
 exit