Local Connect / Local Switching

IOS: ME3600 port to port

interface TenGigabitEthernet0/1
 switchport trunk allowed vlan none
 switchport mode trunk
 load-interval 30
 service instance 1 ethernet
  encapsulation default

interface TenGigabitEthernet0/2
 switchport trunk allowed vlan none
 switchport mode trunk
 load-interval 30
 service instance 2 ethernet
  encapsulation default

connect Name-Te1-Te2 TenGigabitEthernet0/1 1 TenGigabitEthernet0/2 2

IOS: Vlan to Vlan

interface FastEthernet0/0.1
 encapsulation dot1q 1

interface FastEthernet0/0.2
 encapsulation dot1q 2

connect VLAN2VLAN FastEthernet0/0.1 FastEthernet0/0.2

IOS: 892 Internetworking (across VLANs)

interface GigabitEthernet0.2065
 encapsulation dot1Q 2065
 no ip address

interface FastEthernet1
 switchport access vlan 20
 no ip address

interface Vlan20
 desc USP-MGMT
 no ip address

connect UPS Vlan20 GigabitEthernet0.2065 interworking Ethernet

IOS-XR: VLAN to VLAN

interface TenGigE0/0/0/0.1 l2transport
 dot1q vlan 100

interface TenGigE0/0/0/0.2 l2transport
 dot1q vlan 200

l2vpn
 xconnect group XCONGRP
  p2p LS-P2P
   interface TenGigE0/0/0/0.1
   interface TenGigE0/0/0/0.2