VRF Basic Route Leaking

All Cisco 7206's running c7200-jk9s-mz.124-14b.

R1 - MPLS PE - Site A for Customer 1 imports routes from Customer 2 Site A and vice verse

PE1#show ip route vrf Cust1SiteA
      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.11.0.0/24 is directly connected, FastEthernet0/0
L        10.11.0.1/32 is directly connected, FastEthernet0/0
B        10.12.0.0/24
           is directly connected (Cust2SiteA), 00:20:16, FastEthernet0/1
L        10.12.0.1/32 is directly connected, FastEthernet0/1
B        10.61.0.0/24 [200/0] via 10.0.0.6, 00:20:16

PE1#show ip route vrf Cust2SiteA
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B        10.11.0.0/24
           is directly connected (Cust1SiteA), 00:20:22, FastEthernet0/0
L        10.11.0.1/32 is directly connected, FastEthernet0/0
C        10.12.0.0/24 is directly connected, FastEthernet0/1
L        10.12.0.1/32 is directly connected, FastEthernet0/1

CE1A#show ip route
B*    0.0.0.0/0 [20/0] via 10.11.0.1, 00:20:34
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.11.0.0/24 is directly connected, FastEthernet0/0
L        10.11.0.2/32 is directly connected, FastEthernet0/0
B        10.12.0.0/24 [20/0] via 10.11.0.1, 00:20:34
B        10.61.0.0/24 [20/0] via 10.11.0.1, 00:20:34


PE2#show ip route vrf Cust1SiteB
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B        10.11.0.0/24 [200/0] via 10.0.0.1, 00:21:31
C        10.61.0.0/24 is directly connected, FastEthernet0/0
L        10.61.0.6/32 is directly connected, FastEthernet0/0
ip vrf Cust1SiteA
 rd 123:100
 route-target export 123:100
 route-target export 123:1001
 route-target import 123:100
 route-target import 123:1002
!
ip vrf Cust2SiteA
 rd 123:200
 route-target export 123:200
 route-target export 123:1002
 route-target import 123:200
 route-target import 123:1001
!
interface loopback0
 ip address 10.0.0.1 255.255.255.255
 exit
!
mpls label protocol ldp
mpls ldp router-id lo0 force
!
router ospf 1
 router-id 10.0.0.1
 passive-interface default
 no passive-interface fa1/0
 network 10.0.0.1 0.0.0.0 area 0
!
router bgp 65000
 bgp log-neighbor-changes
 neighbor 10.0.0.6 remote-as 65000
 neighbor 10.0.0.6 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.0.0.6 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.0.0.6 activate
 neighbor 10.0.0.6 send-community extended
 neighbor 10.0.0.6 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf Cust2SiteA
 redistribute connected
 neighbor 10.12.0.2 remote-as 65200
 neighbor 10.12.0.2 activate
 neighbor 10.12.0.2 next-hop-self
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf Cust1SiteA
 redistribute connected
 neighbor 10.11.0.2 remote-as 65100
 neighbor 10.11.0.2 activate
 neighbor 10.11.0.2 next-hop-self
 neighbor 10.11.0.2 default-originate
 no synchronization
 exit-address-family
 exit
!
interface FastEthernet0/0
 description Link to CE1A
 ip vrf forwarding Cust1SiteA
 ip address 10.11.0.1 255.255.255.0
!
interface FastEthernet0/1
 description Link to CE2A
 ip vrf forwarding Cust2SiteA
 ip address 10.12.0.1 255.255.255.0
 mpls ip
!
interface FastEthernet1/0
 description Link to PE2
 ip address 10.0.16.1 255.255.255.0
 ip ospf 1 area 0
 mpls ip

CEA1 - Basic eBGP Session

interface FastEthernet0/0
 description Link to PE1
 ip address 10.11.0.2 255.255.255.0
 exit
!
router bgp 65100
 no synchronization
 bgp log-neighbor-changes
 network 10.11.1.1 mask 255.255.255.255
 neighbor 10.11.0.1 remote-as 65000
 no auto-summary

CEB1 - Basic eBGP Session

interface FastEthernet0/0
 description Link to PE1
 ip address 10.12.0.2 255.255.255.0
!
router bgp 65200
 no synchronization
 bgp log-neighbor-changes
 network 10.12.1.1 mask 255.255.255.255
 neighbor 10.12.0.1 remote-as 65000
 neighbor 10.12.0.1 next-hop-self
 no auto-summary

R6 - MPLS PE - No VRF route leaking, Customer 1 Site B can only see's Cust 1 Site A

ip vrf Cust1SiteB
 rd 123:100
 route-target export 123:100
 route-target import 123:100
!
interface loopback0
 ip address 10.0.0.6 255.255.255.255
 exit
!
router ospf 1
 router-id 10.0.0.6
 passive-interface default
 no passive-interface fa1/0
 network 10.0.0.6 0.0.0.0 area 0
 exit
!
mpls label proto ldp
mpls ldp router-id lo0 force
!
router bgp 65000
 bgp log-neighbor-changes
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.0.0.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.0.0.1 activate
 neighbor 10.0.0.1 send-community extended
 neighbor 10.0.0.1 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf Cust1SiteB
 redistribute connected
 neighbor 10.61.0.1 remote-as 65100
 neighbor 10.61.0.1 activate
 neighbor 10.61.0.1 next-hop-self
 neighbor 10.61.0.1 default-originate
 no synchronization
 exit-address-family
 exit
!
interface FastEthernet1/0
 description Link to PE1
 ip address 10.0.16.6 255.255.255.0
 ip ospf 1 area 0
 mpls ip
!
interface FastEthernet0/0
 description Link to Cust1SiteB
 ip vrf forwarding Cust1SiteB
 ip address 10.61.0.6 255.255.255.0

CEA2 - Basic eBGP Session

interface FastEthernet0/0
 description Link to PE6
 ip address 10.61.0.1 255.255.255.0
 exit
!
router bgp 65100
 bgp log-neighbor-changes
 neighbor 10.61.0.6 remote-as 65000
 !
 address-family ipv4
 neighbor 10.61.0.6 activate
 neighbor 10.61.0.6 next-hop-self
 no auto-summary
 no synchronization
 network 10.61.1.1 mask 255.255.255.255
 exit-address-family