Date created: Thursday, December 8, 2016 12:49:00 PM. Last modified: Wednesday, March 21, 2018 8:40:48 AM

Multilink PPPoE

In this example there are two (or more) Ethernet circuits between the subscriber and service provider in the local OLO/CLEC PoP, telco exchange or LLU space. The combined throughput of per-packet load balancing is required without the issues that can arise due to packets being received out of order. Here Multilink PPP is run over the two (or more) Ethernet connection (MLPPPoE) between the CPE and edge PE device to give double the throughput to even a single IP flow.

!ASR1001 test PE using IOS-XE 3.16.4aS:

aaa authentication ppp default local
!
aaa authorization network default local
!
aaa policy interface-config allow-subinterface
!
username test-cpe priv 15 password test-cpe
! ^ This needs fixing, a priv 15 account can not be used outside of the lab !
!
bba-group pppoe global
 virtual-template 1
!
interface Loopback50
 ip address 192.168.50.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
!
interface GigabitEthernet0/0/0
 description 1941-Gi0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 negotiation auto
 pppoe enable group global
!
interface GigabitEthernet0/0/1
 description 1941-Gi0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 negotiation auto
 pppoe enable group global
!
interface Virtual-Template1
 mtu 1492
 bandwidth 40000
 bandwidth receive 10000
 ip unnumbered Loopback50
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no logging event link-status
 no peer default ip address
 no snmp trap link-status
 no keepalive
 ppp authentication chap callin
 ppp multilink


! The 1941 CPE running 15.4(1)T1 is very standard:
interface GigabitEthernet0/0
 description ASR1K-Gi0/0/0
 bandwidth 10000
 bandwidth receive 40000
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface GigabitEthernet0/1
 description ASR1K-Gi0/0/1
 mtu 1492
 bandwidth 10000
 bandwidth receive 40000
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface Dialer0
 mtu 1492
 bandwidth 20000
 bandwidth receive 80000
 ip address 192.168.50.5 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 load-interval 30
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname test-cpe
 ppp chap password 0 test-cpe
 ppp multilink
 no cdp enable