Date created: 05/22/13 14:52:58. Last modified: 02/07/18 16:19:37

NAT

Basic NAT config for a traditional CPE;

ip dhcp excluded-address 192.168.0.1 192.168.0.99
!
ip dhcp pool LAN
   network 192.168.0.0 255.255.255.0
   dns-server 1.1.1.1 2.2.2.2
   default-router 192.168.0.1 
   domain-name domain.net
!
ip domain name domain.net
!
interface FastEthernet0/0
 description LAN
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
!
interface Dialer1
 desc WAN
 ip nat outside
 ip virtual-reassembly
!
!
ip nat translation tcp-timeout 500
ip nat translation udp-timeout 1200
ip nat translation finrst-timeout 30
ip nat translation syn-timeout 30
ip nat translation dns-timeout 30
ip nat translation icmp-timeout 30
ip nat inside source list 10 interface Dialer1 overload
!
!
access-list 10 permit 192.168.0.0 0.0.0.255