PWE3 IOS to IOS-XR (7600 & 6500 to ASR9K)

7600 to ASR9001 Port-to-Sub-int


This is an example of a port based pseudowire on the 7600 end to a VLAN tagged sub-interface on the ASR9001. The ASR9001 must pop the incoming VLAN tag and push one on egress as the 7600 side is untagged (port level pseudowire):

# ASR9001 + XR-5.3.3
l2vpn
 pw-class PW_VLAN
  encapsulation mpls
   transport-mode Ethernet
 !
 xconnect group LHC-LD5-DCC-XCONNECT-2
  p2p lhc-ld5-2
   interface TenGigE0/0/2/3.1502
   neighbor ipv4 10.0.0.254 pw-id 1502
    pw-class PW_VLAN
!
interface TenGigE0/0/2/3.1502 l2transport
 description L2-LHC-LD5-DCC-XCONNECT-2
 encapsulation dot1q 1502
 rewrite ingress tag pop 1 symmetric
 mtu 1518



RP/0/RSP0/CPU0:ASR9001#show int te0/0/2/3 | inc MTU

  MTU 1514 bytes, BW 10000000 Kbit (Max: 10000000 Kbit)


RP/0/RSP0/CPU0:ASR9001#show int te0/0/2/3.1502 | inc MTU

  MTU 1518 bytes, BW 10000000 Kbit (Max: 10000000 Kbit)



# 7606 + RSP720-3CXL-10G + 15.3(3)S6
interface GigabitEthernet3/9
 description DCC-PA-XCONNECT-2
 no ip address
 wrr-queue bandwidth 100 100 100
 priority-queue queue-limit 100
 wrr-queue queue-limit 100 100 100
 wrr-queue threshold 1 100 100 100 100 100 100 100 100
 wrr-queue threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue random-detect min-threshold 3 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
 wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100
 wrr-queue cos-map 2 1 1
 wrr-queue cos-map 2 2 2
 wrr-queue cos-map 2 3 3
 wrr-queue cos-map 2 4 4
 rcv-queue threshold 1 100 100 100 100 100 100 100 100
 rcv-queue cos-map 1 2 1
 rcv-queue cos-map 1 3 2
 rcv-queue cos-map 1 4 3
 rcv-queue cos-map 1 5 4
 rcv-queue cos-map 1 6 5
 rcv-queue cos-map 1 7 6 7
 mls qos trust dscp
 no keepalive
 no cdp enable
 xconnect 10.0.0.2 1502 encapsulation mpls


7606#show int gi3/9 | inc MTU
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,


7606#show xconnect interface gi3/9 detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi3/9:109(Ethernet)          UP mpls 10.0.0.2:1502                UP
            Interworking: none                   Local VC label 99937
                                                 Remote VC label 52178

7606#show mpls l2transport binding 1502
  Destination Address: 10.0.0.2,VC ID: 1502
    Local Label:  99937
        Cbit: 0,    VC Type: Ethernet,    GroupID: 0
        MTU: 1500,   Interface Desc: DCC-PA-XCONNECT-2
        VCCV: CC Type: RA [2], TTL [3]
              CV Type: LSPV [2], BFD/Raw [5]
    Remote Label: 52178
        Cbit: 0,    VC Type: Ethernet,    GroupID: 67110784
        MTU: 1500,   Interface Desc: TenGigE0_0_2_3.1502
        VCCV: CC Type: RA [2], TTL [3]
              CV Type: LSPV [2]

7606#show mpls l2transport vc 1502 detail
Local interface: Gi3/9 up, line protocol up, Ethernet up
  Destination address: 10.0.0.2, VC ID: 1502, VC status: up
    Output interface: Te4/1, imposed label stack {219 52178}
    Preferred path: not configured
    Default path: active
    Next hop: 10.0.0.250
  Create time: 10w6d, last status change time: 2w1d
    Last label FSM state change time: 2w1d
  Signaling protocol: LDP, peer 10.0.0.2:0 up
    Targeted Hello: 10.0.0.254(LDP Id) -> 10.0.0.2, LDP is UP
    Graceful restart: not configured and not enabled
    Non stop routing: not configured and not enabled
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last BFD dataplane     status rcvd: Not sent
      Last BFD peer monitor  status rcvd: No fault
      Last local AC  circuit status rcvd: No fault
      Last local AC  circuit status sent: No fault
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV     status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 99937, remote 52178
    Group ID: local 0, remote 67110784
    MTU: local 1500, remote 1500
    Remote interface description: TenGigE0_0_2_3.1502
  Sequencing: receive disabled, send disabled
  Control Word: Off (configured: autosense)
  SSO Descriptor: 10.0.0.2/1502, local label: 99937
  Dataplane:
    SSM segment/switch IDs: 43840/11043 (used), PWID: 13
  VC statistics:
    transit packet totals: receive 0, send 1637887
    transit byte totals:   receive 0, send 154693010
    transit packet drops:  receive 0, seq error 0, send 0


RP/0/RSP0/CPU0:ASR9001#show l2vpn xconnect pw-id 1502 detail

Group LHC-LD5-DCC-XCONNECT-2, XC lhc-ld5-2, state is up; Interworking none
  AC: TenGigE0/0/2/3.1502, state is up
    Type VLAN; Num Ranges: 1
    VLAN ranges: [1502, 1502]
    MTU 1500; XC ID 0x1080030; interworking none
    Statistics:
      packets: received 0, sent 1639123
      bytes: received 0, sent 125305716
      drops: illegal VLAN 0, illegal length 0
  PW: neighbor 10.0.0.254, PW ID 1502, state is up ( established )
    PW class PW_VLAN, XC ID 0xc0000018
    Encapsulation MPLS, protocol LDP
    Source address 10.0.0.2
    PW type Ethernet, control word disabled, interworking none
    PW backup disable delay 0 sec
    Sequencing not set

    PW Status TLV in use
      MPLS         Local                          Remote
      ------------ ------------------------------ -----------------------------
      Label        52178                          99937
      Group ID     0x4000780                      unknown
      Interface    TenGigE0/0/2/3.1502            DCC-PA-XCONNECT-2
      MTU          1500                           1500
      Control word disabled                       disabled
      PW type      Ethernet                       Ethernet
      VCCV CV type 0x2                            0x12
                   (LSP ping verification)        (LSP ping verification)
      VCCV CC type 0x6                            0x6
                   (router alert label)           (router alert label)
                   (TTL expiry)                   (TTL expiry)
      ------------ ------------------------------ -----------------------------
    Incoming Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    Outgoing Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    MIB cpwVcIndex: 3221225496
    Create time: 27/07/2017 21:33:39 (25w6d ago)
    Last time status changed: 09/01/2018 20:27:37 (2w1d ago)
    Last time PW went down: 09/11/2017 20:31:03 (10w6d ago)
    Statistics:
      packets: received 1639123, sent 0
      bytes: received 125305716, sent 0


RP/0/RSP0/CPU0:ASR9001#show l2vpn forwarding xconnect 0x1080030 detail location 0/0/CPU0

Local interface: TenGigE0/0/2/3.1502, Xconnect id: 0x1080030, Status: up
  Segment 1
    AC, TenGigE0/0/2/3.1502, status: Bound
    Statistics:
      packets: received 0, sent 1639483
      bytes: received 0, sent 125332701
  Segment 2
    MPLS, Destination address: 10.0.0.254, pw-id: 1502, status: Bound
    Pseudowire label: 99937    Control word disabled
    Statistics:
      packets: received 1639483, sent 0
      bytes: received 125332701, sent 0

7600 to ASR9001 Sub-int-to-Sub-tin

When using LAN cards in a 7600 for xconnects there are several limitations like the access-circuits being the same type at each end of the pseudowire (SVI to SVI and sub-int to sub-int etc). The 7600 can not handle interworking like xconnect'ing an SVI to a sub-int on an ASR9001 for example. This is because LAN cards are unable to push the EoMPLS label on to the label stack on egress facing the other PE when sending local xconnect traffic in to the core towards the remote xconnect PE end device. The core facing line card should be SIP-400, SIP-600, ES20 or ES+ line card

This is a working config using MUX-UNI on the 7600 (IOS 15.2(4)S4) to xconnect a sub-int of a L2 trunk port, to a sub-int on an L3 ASR9001 (XR 4.3.4) port:

ASR9K1 - IOS-XR 4.3.4 

interface GigabitEthernet0/0/0/13.2007 l2transport
 description Xconnect to Other-PE gi2/6.2007
 encapsulation dot1q 2007
 rewrite ingress tag pop 1 symmetric
 mtu 1518

! Remember the MTU on IOS-XR has to include the Ethernet headers (14 bytes) and VLAN tag (4 bytes)

l2vpn
 xconnect group PE_to_PE_Xconnect
  p2p pe-to-pe
   interface GigabitEthernet0/0/0/13.2007
   neighbor ipv4 10.0.0.1 pw-id 22253


7606-S - 15.2(4)S4

interface GigabitEthernet2/6
 description Local Trunk Termination
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2000-2006
 switchport mode trunk
 mtu 9216
 wrr-queue cos-map 1 1 1
 wrr-queue cos-map 2 1 0
 wrr-queue cos-map 3 1 4
 wrr-queue cos-map 3 2 2
 wrr-queue cos-map 3 3 3
 wrr-queue cos-map 3 4 6
 wrr-queue cos-map 3 5 7
 no cdp enable

interface GigabitEthernet2/6.2007
 description MUX-UNI Xconnect to Different-PE gi0/0/0/13.2007
 encapsulation dot1Q 2007
 xconnect 10.0.0.2 22253 encapsulation mpls
  mtu 1500

  ! 7600/IOS includes the 18 bytes of header automatically



PE-ABC#show xconnect interface gi2/6.2007 detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi2/6.2007:2007(Eth VLAN)    UP mpls 10.0.0.2:22253               UP
            Interworking: ethernet               Local VC label 13541
                                                 Remote VC label 26161




PE-ABC#show mpls l2transport vc 22253 detail
Local interface: Gi2/6.2007 up, line protocol up, Eth VLAN 2007 up
  Interworking type is Ethernet
  Destination address: 10.0.0.2, VC ID: 22253, VC status: up
    Output interface: Te3/2, imposed label stack {26161}
    Preferred path: not configured
    Default path: active
    Next hop: 10.0.249.1
  Create time: 20w0d, last status change time: 20w0d
    Last label FSM state change time: 20w0d
  Signaling protocol: LDP, peer 10.0.0.2:0 up
    Targeted Hello: 10.0.0.1(LDP Id) -> 10.0.0.2, LDP is UP
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last BFD dataplane     status rcvd: Not sent
      Last BFD peer monitor  status rcvd: No fault
      Last local AC  circuit status rcvd: No fault
      Last local AC  circuit status sent: No fault
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV     status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 13541, remote 26161
    Group ID: local 0, remote 67109888
    MTU: local 1500, remote 1500
    Remote interface description: GigabitEthernet0_0_0_13.2007
  Sequencing: receive disabled, send disabled
  Control Word: Off (configured: autosense)
  SSO Descriptor: 10.0.0.2/22253, local label: 13541
  Dataplane:
    SSM segment/switch IDs: 24825/16632 (used), PWID: 5
  VC statistics:
    transit packet totals: receive 140730671, send 139223607
    transit byte totals:   receive 10771976783, send 11946984984
    transit packet drops:  receive 0, seq error 0, send 0




PE-ABC#show mpls l2transport binding 22253
  Destination Address: 10.0.0.2,VC ID: 22253
    Local Label:  13541
        Cbit: 0,    VC Type: Ethernet,    GroupID: 0
        MTU: 1500,   Interface Desc: n/a
        VCCV: CC Type: RA [2], TTL [3]
              CV Type: LSPV [2], BFD/Raw [5]
    Remote Label: 26161
        Cbit: 0,    VC Type: Ethernet,    GroupID: 67109888
        MTU: 1500,   Interface Desc: GigabitEthernet0_0_0_13.2007
        VCCV: CC Type: RA [2], TTL [3]
              CV Type: LSPV [2]




RP/0/RSP0/CPU0:PE-123#show l2vpn xconnect interface gi0/0/0/13.2007 detail

Group PE_to_PE_Xconnect, XC pe-to-pe, state is up; Interworking none
  AC: GigabitEthernet0/0/0/13.2007, state is up
    Type VLAN; Num Ranges: 1
    VLAN ranges: [2007, 2007]
    MTU 1500; XC ID 0x1080017; interworking none
    Statistics:
      packets: received 0, sent 0
      bytes: received 0, sent 0
      drops: illegal VLAN 0, illegal length 0
  PW: neighbor 10.0.0.1, PW ID 22253, state is up ( established )
    PW class not set, XC ID 0xc000000d
    Encapsulation MPLS, protocol LDP
    Source address 10.0.0.2
    PW type Ethernet, control word disabled, interworking none
    PW backup disable delay 0 sec
    Sequencing not set

    PW Status TLV in use
      MPLS         Local                          Remote
      ------------ ------------------------------ -----------------------------
      Label        26161                          13541
      Group ID     0x4000400                      unknown
      Interface    GigabitEthernet0/0/0/13.2007   unknown
      MTU          1500                           1500
      Control word disabled                       disabled
      PW type      Ethernet                       Ethernet
      VCCV CV type 0x2                            0x12
                   (LSP ping verification)        (LSP ping verification)
      VCCV CC type 0x6                            0x6
                   (router alert label)           (router alert label)
                   (TTL expiry)                   (TTL expiry)
      ------------ ------------------------------ -----------------------------
    Incoming Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    Outgoing Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    MIB cpwVcIndex: 3221225485
    Statistics:
      packets: received 0, sent 0
      bytes: received 0, sent 0



RP/0/RSP0/CPU0:PE-123#show l2vpn forwarding interface Gi0/0/0/13.2007 hardware ingress detail location 0/0/CPU0
Local interface: GigabitEthernet0/0/0/13.2007, Xconnect id: 0x1080017, Status: up
  Segment 1
    AC, GigabitEthernet0/0/0/13.2007, status: Bound
    Statistics:
      packets: received 140748669, sent 139240162
      bytes: received 10775167735, sent 11948167205
      packets dropped: PLU 0, tail 0
      bytes dropped: PLU 0, tail 0
  Segment 2
    MPLS, Destination address: OTHER.PE.IP.ADDR, pw-id: 22253, status: Bound
    Pseudowire label: 13541    Control word disabled
    Statistics:
      packets: received 139240162, sent 140748669
      bytes: received 11948167205, sent 10775167735
      packets dropped: PLU 0, tail 0, out of order 0
      bytes dropped: PLU 0, tail 0, out of order 0
  Platform AC context:
  Ingress AC: AToM, State: Bound
    Flags: Remote is PW
  XID: 0x02e00017, SHG: None
  Ingress uIDB: 0x0057, Egress uIDB: 0x0057, NP: 0, Port Learn Key: 0
  NP0
    Ingress uIDB:
      Flags: L2, Status, Ext Required, VLAN Ops
      Stats Ptr: 0x000000, uIDB index: 0x0057, Wire Exp Tag: 1
      BVI Bridge Domain: 0, BVI Source XID: 0x00000000
      VLAN1: 0, VLAN1 etype: 0x0000, VLAN2: 0, VLAN2 etype: 0x0000
      L2 ACL Format: 0, L2 ACL ID: 0, IPV4 ACL ID: 0, IPV6 ACL ID: 0
      QOS ID: 0, QOS Format ID: 0
      Local Switch dest XID: 0xc000800c
      UIDB IF Handle: 0x04000742, Source Port: 0, Num VLANs: 0
    Xconnect ID: 0x02e00017, NP: 0
      Type: AC
      Flags: Learn enable
      uIDB Index: 0x0057
      Split Horizon Group: None

  Platform PW context:
  Ingress PW: AToM, State: Bound
  XID: 0xc000800c, bridge: 0, MAC limit: 0, l2vpn ldi index: 0x0004, vc label: 13541,
  nr_ldi_hash: 0x93, r_ldi_hash: 0xbc, lag_hash: 0x2a, SHG: None
    Flags: None
  NP0
    Xconnect ID: 0xc000800c, NP: 0
      Type: Pseudowire (no control word)
      Flags: Learn enable, Type 5, Local replication
      VC label hash, nR-LDI Hash: 0x93, R-LDI Hash: 0xf7, LAG Hash: 0x2a,
      VC output label: 0x034e5 (13541), LDI: 0x0004, stats ptr: 0x00000000
      Split Horizon Group: None
  NP1
    Xconnect ID: 0xc000800c, NP: 1
      Type: Pseudowire (no control word)
      Flags: Learn enable, Type 5, Local replication
      VC label hash, nR-LDI Hash: 0x93, R-LDI Hash: 0xf7, LAG Hash: 0x2a,
      VC output label: 0x034e5 (13541), LDI: 0x0004, stats ptr: 0x00000000
      Split Horizon Group: None

6500 to ASR9006 Sub-int-to-Sub-int

This is a 6500 (15.1(1)SY1) sub-interface to ASR9006 (XR: 5.1.2) sub-interface, which means the pseudowire is taking accepting traffic on tagged sub-interface at each end. Due to the rewrite command at the IOS-XR end the VLAN tag is pop'ed before its processed for forwarding (passed to the L2VPN in this case). The IOS 6500 does the same process automatically by having the "xconnect" statment on the sub-interface of a L3 interface, the same rewrite operation is implied. The 6500 here is using all LAN cards.

IOS-XR:
l2vpn
 xconnect group test-VC117
  p2p XR-to-IOS-vc117
   interface TenGigE0/0/0/3.3406
   neighbor ipv4 10.0.0.10 pw-id 117


interface TenGigE0/0/0/3.3406 l2transport
 description PERF-Link-Test:VC117
 encapsulation dot1q 3406
 rewrite ingress tag pop 1 symmetric
 mtu 1518




IOS:

interface GigabitEthernet2/8/30.3406
 description PERF-Link-Test:VC117
 encapsulation dot1Q 3406
 xconnect 10.0.0.11 117 encapsulation mpls
end




RP/0/RSP1/CPU0:IOS-XR#show l2vpn xconnect pw-id 117 detail

Group test-VC117, XC XR-to-IOS-vc117, state is up; Interworking none
  AC: TenGigE0/0/0/3.3406, state is up
    Type VLAN; Num Ranges: 1
    VLAN ranges: [3406, 3406]
    MTU 1500; XC ID 0x1080001; interworking none
    Statistics:
      packets: received 2856, sent 2753
      bytes: received 195666, sent 176196
      drops: illegal VLAN 0, illegal length 0
  PW: neighbor 10.0.0.10, PW ID 117, state is up ( established )
    PW class not set, XC ID 0xc0000002
    Encapsulation MPLS, protocol LDP
    Source address 10.0.0.11
    PW type Ethernet, control word disabled, interworking none
    PW backup disable delay 0 sec
    Sequencing not set

    PW Status TLV in use
      MPLS         Local                          Remote
      ------------ ------------------------------ -----------------------------
      Label        1048572                        136
      Group ID     0x4000180                      unknown
      Interface    TenGigE0/0/0/3.3406            PERF-Link-Test:VC117
      MTU          1500                           1500
      Control word disabled                       disabled
      PW type      Ethernet                       Ethernet
      VCCV CV type 0x2                            0x2
                   (LSP ping verification)        (LSP ping verification)
      VCCV CC type 0x6                            0x2
                   (router alert label)           (router alert label)
                   (TTL expiry)
      ------------ ------------------------------ -----------------------------
    Incoming Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    Outgoing Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    MIB cpwVcIndex: 3221225474
    Create time: 16/06/2015 18:53:17 (02:50:01 ago)
    Last time status changed: 16/06/2015 21:43:06 (00:00:12 ago)
    Last time PW went down: 16/06/2015 21:42:07 (00:01:11 ago)
    Statistics:
      packets: received 2753, sent 2856
      bytes: received 176196, sent 195666




6500#show mpls l2transport vc 117 detail
Local interface: Gi2/8/30.3406 up, line protocol up, Eth VLAN 3406 up
  Interworking type is Ethernet
  Destination address: 10.0.0.11, VC ID: 117, VC status: up
    Output interface: Te1/1/2, imposed label stack {16000 1048572}
    Preferred path: not configured
    Default path: active
    Next hop: 10.0.0.69
  Load Balance: none
  Flow Label: Disabled
  Create time: 02:20:50, last status change time: 00:32:55
  Signaling protocol: LDP, peer 10.0.0.11:0 up
    Targeted Hello: 10.0.0.10(LDP Id) -> 10.0.0.11
    Status TLV support (local/remote)   : enabled/supported
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: no fault
      Last local SSS circuit status rcvd: no fault
      Last local SSS circuit status sent: no fault
      Last local  LDP TLV    status sent: no fault
      Last remote LDP TLV    status rcvd: no fault
    MPLS VC labels: local 136, remote 1048572
    Group ID: local 0, remote 67109248
    MTU: local 1500, remote 1500
    Remote interface description: TenGigE0_0_0_3.3406
  Sequencing: receive disabled, send disabled
  VC statistics:
    packet totals: receive 31496, send 30434
    byte totals:   receive 13339492, send 13254096
    packet drops:  receive 0, seq error 0, send 0





6500#show mpls l2transport binding 117
  Destination Address: 10.0.0.11,  VC ID: 117
    Local Label:  136
        Cbit: 0,    VC Type: Ethernet,    GroupID: 0
        MTU: 1500,   Interface Desc: PERF-Link-Test:VC117
        VCCV: CC Type: RA [2]
              CV Type: LSPV [2]
    Remote Label: 1048572
        Cbit: 0,    VC Type: Ethernet,    GroupID: 67109248
        MTU: 1500,   Interface Desc: TenGigE0_0_0_3.3406
        VCCV: CC Type: RA [2], TTL [3]
              CV Type: LSPV [2]

6500 to ASR9006 - Port-to-Port

This is a port-based pseudowire from a 6500 using LAN cards WS-X6908-10G with VS-SUP2T-10G on 15.1(1)SY1 to an ASR9006 on IOS-XR  5.1.2 Default with A9K-MOD80-SE and A9K-MPA-4X10GE. VC type is shown as VC type 5 "Ethernet":

RP/0/RSP1/CPU0:ASR9006#show run int te0/1/0/3
Wed Jul 29 17:01:37.017 BST
interface TenGigE0/1/0/3
 description MGMT-PERF_EoMPLS_Connections_to_DC2-PE1_for_Inter_ABC_traffic
 mtu 9216
 l2transport
 

RP/0/RSP1/CPU0:ASR9006#show l2vpn forwarding interface te0/1/0/3 hardware ingress detail location 0/1/CPU0
Wed Jul 29 16:55:27.436 BST
Local interface: TenGigE0/1/0/3, Xconnect id: 0x1880001, Status: up
  Segment 1
    AC, TenGigE0/1/0/3, Ethernet port mode, status: Bound
    Statistics:
      packets: received 2829955572, sent 8926732640
      bytes: received 2249862103275, sent 11924994739192
      packets dropped: PLU 0, tail 0
      bytes dropped: PLU 0, tail 0
  Segment 2
    MPLS, Destination address: 172.31.96.10, pw-id: 106, status: Bound
    Pseudowire label: 108    Control word disabled
    Statistics:
      packets: received 8926732640, sent 2829955572
      bytes: received 11924994739192, sent 2249862103275
      packets dropped: PLU 0, tail 0, out of order 0
      bytes dropped: PLU 0, tail 0, out of order 0
  Platform AC context:
  Ingress AC: AToM, State: Bound
    Flags: Remote is PW
  XID: 0x04680001, SHG: None
  Ingress uIDB: 0x0004, Egress uIDB: 0x0004, NP: 0, Port Learn Key: 0
  NP0
    Ingress uIDB:
      Flags: L2, Status
      Stats Ptr: 0x5300ab, uIDB index: 0x0004, Wire Exp Tag: 0
      BVI Bridge Domain: 0, BVI Source XID: 0x00000000
      VLAN1: 0, VLAN1 etype: 0x0000, VLAN2: 0, VLAN2 etype: 0x0000
      L2 ACL Format: 0, L2 ACL ID: 0, IPV4 ACL ID: 0, IPV6 ACL ID: 0
      QOS ID: 0, QOS Format ID: 0
      Local Switch dest XID: 0xc0008000
      UIDB IF Handle: 0x06000180, Source Port: 0, Num VLANs: 0
    Xconnect ID: 0x04680001, NP: 0
      Type: AC
      Flags: Learn enable
      uIDB Index: 0x0004
      Split Horizon Group: None

  Platform PW context:
  Ingress PW: AToM, State: Bound
  XID: 0xc0008000, bridge: 0, MAC limit: 0, l2vpn ldi index: 0x0001, vc label: 108,
  nr_ldi_hash: 0xdd, r_ldi_hash: 0xfe, lag_hash: 0x5, SHG: None
    Flags: None
  NP0
    Xconnect ID: 0xc0008000, NP: 0
      Type: Pseudowire (no control word)
      Flags: Learn enable, Type 5, Local replication
      VC label hash, nR-LDI Hash: 0xdd, R-LDI Hash: 0x3f, LAG Hash: 0x05,
      VC output label: 0x0006c (108), LDI: 0x0001, stats ptr: 0x00000000
      Split Horizon Group: None
  NP1
    Xconnect ID: 0xc0008000, NP: 1
      Type: Pseudowire (no control word)
      Flags: Learn enable, Type 5, Local replication
      VC label hash, nR-LDI Hash: 0xdd, R-LDI Hash: 0x3f, LAG Hash: 0x05,
      VC output label: 0x0006c (108), LDI: 0x0001, stats ptr: 0x00000000
      Split Horizon Group: None


6500#show run int Te2/1/4
interface TenGigabitEthernet2/1/4
 description *** EoMPLS Connections to DC1 PE2 for Inter XYZ Traffic ***
 no switchport
 mtu 9202
 no ip address
 no keepalive
 xconnect 172.31.96.12 106 encapsulation mpls

6500#show mpls l2transport binding 106
  Destination Address: 172.31.96.12,  VC ID: 106
    Local Label:  108
        Cbit: 0,    VC Type: Ethernet,    GroupID: 0
        MTU: 9202,   Interface Desc: *** EoMPLS Connections to DC2 PE2 for Inter XYZ Traffic ***
        VCCV: CC Type: RA [2]
              CV Type: LSPV [2]
    Remote Label: 16010
        Cbit: 0,    VC Type: Ethernet,    GroupID: 100663680
        MTU: 9202,   Interface Desc: TenGigE0_1_0_3
        VCCV: CC Type: RA [2], TTL [3]
              CV Type: LSPV [2]


6500#show mpls l2transport vc 106 detail
Local interface: Te2/1/4 up, line protocol up, Ethernet up
  Destination address: 172.31.96.12, VC ID: 106, VC status: up
    Output interface: Te1/1/2, imposed label stack {16010}
    Preferred path: not configured
    Default path: active
    Next hop: 172.31.98.69
  Load Balance: none
  Flow Label: Disabled
  Create time: 2w1d, last status change time: 2w1d
  Signaling protocol: LDP, peer 172.31.96.12:0 up
    Targeted Hello: 172.31.96.10(LDP Id) -> 172.31.96.12
    Status TLV support (local/remote)   : enabled/supported
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: no fault
      Last local SSS circuit status rcvd: no fault
      Last local SSS circuit status sent: no fault
      Last local  LDP TLV    status sent: no fault
      Last remote LDP TLV    status rcvd: no fault
    MPLS VC labels: local 108, remote 16010
    Group ID: local 0, remote 100663680
    MTU: local 9202, remote 9202
    Remote interface description: TenGigE0_1_0_3
  Sequencing: receive disabled, send disabled
  SSO Descriptor: 172.31.96.12/106, local label: 108
    SSM segment/switch IDs: 90190/24620 (used), PWID: 73780
  VC statistics:
    packet totals: receive 2731716132, send 8738075235
    byte totals:   receive 2246901366946, send 11721357190928
    packet drops:  receive 0, seq error 0, send 0


Previous page: PWE3 Access/Untagged
Next page: PWE3 IOS & XR to Junos