Date created: 04/19/16 09:38:49. Last modified: 12/21/17 15:59:23

VPLS IOS-XR to Junos

IOS-XR:
show l2vpn bridge-domain bd-name xxxx detail
show bgp l2vpn vpls

RFC4761 - VPLS using BGP Auto Discovery and BGP for signaling for a full mesh of PWEs/LSPs

! Junos
set protocols mpls interface ge-1/3/0.0
set protocols ldp interface ge-1/3/0.0
set protocols ldp interface lo0.0

set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 1.1.1.1
set protocols bgp group ibgp family inet-vpn unicast
set protocols bgp group ibgp family l2vpn signaling
set protocols bgp group ibgp neighbor 1.1.1.2 local-as 65000

set interfaces ge-1/3/2 encapsulation ethernet-vpls
set interfaces ge-1/3/2 unit 0 family vpls

set routing-instance vlan100 instance-type vpls
set routing-instance vlan100 interface ge-1/3/2.0
set routing-instance vlan100 route-distinguisher 1.1.1.1:100
set routing-instance vlan100 vrf-target target:65000:100
set routing-instance vlan100 protocols vpls
set routing-instance vlan100 protocols vpls site-range 8
set routing-instance vlan100 protocols vpls no-tunnel-service
set routing-instance vlan100 protocols vpls site my_site site-identifier 2
set routing-instance vlan100 protocols vpls site my_site interface ge-1/3/2.0



! IOS-XR
router bgp 65000
 neighbor-group ibgp-pe
  remote-as 65000
  update-source Loopback0
  address-family l2vpn vpls-vpws
   signalling ldp disable   ! Required to used BGP for signalling
   exit
  exit
 
 neighbor 1.1.1.1
  use neighbor-group ibgp-pe
  exit

 exit

l2vpn
 autodiscovery bgp
  signaling-protocol bgp
   mtu mismatch ignore
   exit
  exit

 bridge group v100
  bridge-domain v100
   interface TenGigE0/0/0/0.100
   vfi v100
    vpn-id 100
    autodiscovery bgp
     rd auto
     route-target import 65000:100
     route-target export 65000:100
     signaling-protocol bgp
      ve-id 5
      ve-range 11
      exit
     exit
    exit
   exit
 exit

interface TenGigE0/0/0/0.100 l2transport
 encapsulation dot1q 100
 rewrite ingress tag pop 1 symmetric
 exit

RFC4762 - VPLS using BGP Auto Discovery and LDP for signaling for a full mesh pf PWEs/LSPs

! Junos
set protocols mpls interface ge-1/3/0.0
set protocols ldp interface ge-1/3/0.0
set protocols ldp interface lo0.0

set protocols bgp group ibgp type internal
set protocols bgp group ibgp local-address 1.1.1.1
set protocols bgp group ibgp family inet-vpn unicast
set protocols bgp group ibgp family l2vpn auto-discovery-only
set protocols bgp group ibgp neighbor 1.1.1.2 local-as 65000

set interfaces ge-1/3/2 encapsulation ethernet-vpls
set interfaces ge-1/3/2 unit 0 family vpls

set routing-instances vlan100 instance-type vpls
set routing-instances vlan100 interface ge-1/3/2.0
set routing-instances vlan100 route-distinguisher 1.1.1.1:100
set routing-instances vlan100 l2vpn-id l2vpn-id:65000:100
set routing-instances vlan100 vrf-target target:65000:100
set routing-instances vlan100 protocols vpls no-tunnel-services


! IOS-XR
router bgp 65000
 neighbor-group ibgp-pe
  remote-as 65000
  update-source Loopback0
  address-family l2vpn vpls-vpws
  exit

 neighbor 1.1.1.1
  use neighbor-group ibgp-pe
  exit

 exit

l2vpn
 bridge group v100
  bridge-domain v100
   interface TenGigE0/0/0/0.100
   vfi v100
    vpn-id 100
    autodiscovery bgp
     rd auto
     route-target import 65000:100
     route-target export 65000:100
     signaling-protocol ldp
      vpls-id 65000:100
      exit
     exit
    exit
   exit
  exit

interface TenGigE0/0/0/0.100 l2transport
 encapsulation dot1q 100
 rewrite ingress tag pop 1 symmetric
 exit