Date created: Tuesday, November 15, 2016 12:04:25 PM. Last modified: Tuesday, January 17, 2017 4:57:32 PM

ME3600X/ME3800X Bandwidth, Policer & Shaper Oversubscription

References:
http://www.gossamer-threads.com/lists/cisco/nsp/180172

Contents:
Oversubscribing Egress Bandwidth Reservations
Oversubscribing Egress Policers and Shapers
Oversubscribing Ingress Policers

Oversubscribing Egress Bandwidth Reservations

ME3600X / ME3800X device show this error when applying policy maps that contain bandwidth reservations ("bandwidth percent X" or "bandwidth remaining percent X"):

QoS:Bandwidth oversubscribed in the interface
QoS: Policy attachment failed for policymap PE-QOS-CUSTOMER-OUT

% service-policy PE-QOS-CUSTOMER-OUT of type default is not allowed in policy-map Gi0-10-CUST-SHAPE of type default

This error happens when the total aggregate bandwidth reservations configured against a single port in a hierarchical QoS policy exceeds the physical speed (1Gbps or total aggregate reservations configured on a 1Gbps port or 100Mbps of total aggregate reservations on a 100Mbps port etc).

For example a 1Gbps port which connects to a carrier Ethernet NNI, each VLAN connecting to the NNI is a separate customer and shaped to 100Mbps. Within each customer 100Mbps VLAN shaper a child-policy is applied to create 7 classes of traffic.

interface GigabitEthernet0/10
 switchport trunk allowed vlan none
 switchport mode trunk
 mtu 1530
 no shut
 no cdp enable
 service instance 1 ethernet
  description Cust1
  encapsulation dot1q 1
  rewrite ingress tag pop 1 symmetric
  bridge-domain 1
 !
 service instance 2 ethernet
  description Cust2
  encapsulation dot1q 2
  rewrite ingress tag pop 1 symmetric
  bridge-domain 2
 !
 service instance 3 ethernet
  description Cust3
  encapsulation dot1q 3
  rewrite ingress tag pop 1 symmetric
  bridge-domain 3
 !
 service instance 4 ethernet
  description Cust4
  encapsulation dot1q 4
  rewrite ingress tag pop 1 symmetric
  bridge-domain 4
 !
 service instance 5 ethernet
  description Cust5
  encapsulation dot1q 5
  rewrite ingress tag pop 1 symmetric
  bridge-domain 5
 !
 service instance 6 ethernet
  description Cust6
  encapsulation dot1q 6
  rewrite ingress tag pop 1 symmetric
  bridge-domain 6
 !
 service instance 7 ethernet
  description Cust7
  encapsulation dot1q 7
  rewrite ingress tag pop 1 symmetric
  bridge-domain 7
 !
 service instance 8 ethernet
  description Cust8
  encapsulation dot1q 8
  rewrite ingress tag pop 1 symmetric
  bridge-domain 8
 !
 service instance 9 ethernet
  description Cust9
  encapsulation dot1q 9
  rewrite ingress tag pop 1 symmetric
  bridge-domain 9
 !
 service instance 10 ethernet
  description Cust10
  encapsulation dot1q 10
  rewrite ingress tag pop 1 symmetric
  bridge-domain 10
 !
 service instance 11 ethernet
  description Cust11
  encapsulation dot1q 11
  rewrite ingress tag pop 1 symmetric
  bridge-domain 11
  exit
 exit

These class-maps match each of the 11 customer circuits (VLANs) created above:

class-map match-any CM-Cust1
match service instance ethernet 1
exit
!
class-map match-any CM-Cust2
match service instance ethernet 2
exit
!
class-map match-any CM-Cust3
match service instance ethernet 3
exit
!
class-map match-any CM-Cust4
match service instance ethernet 4
exit
!
class-map match-any CM-Cust5
match service instance ethernet 5
exit
!
class-map match-any CM-Cust6
match service instance ethernet 6
exit
!
class-map match-any CM-Cust7
match service instance ethernet 7
exit
!
class-map match-any CM-Cust8
match service instance ethernet 8
exit
!
class-map match-any CM-Cust9
match service instance ethernet 9
exit
!
class-map match-any CM-Cust10
match service instance ethernet 10
exit
!
class-map match-any CM-Cust11
match service instance ethernet 11
exit

This parent policy-map matches each customer VLAN and creates a 100Mbps shaper and then applies the child-policy to each customer/VLAN shaper (100Mbps pipe):

policy-map Gi0-10-CUST-SHAPE
 class CM-Cust1
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust2
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust3
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust4
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust5
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust6
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust7
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust8
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust9
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust10
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 class CM-Cust11
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 exit

Below is the child-policy configuration that is being applied, the total of all the child-policy percentages is 100% (it cannot exceed the parent shaper/port speed):

policy-map PE-QOS-CUSTOMER-OUT
 class NC-QG
  bandwidth percent 2
  queue-limit percent 100
 class REALTIME-QG
  police cir percent 10
   conform-action transmit
   exceed-action drop
  priority
  queue-limit percent 100
 class APP-1-QG
  bandwidth percent 22
  queue-limit percent 100
 class APP-2-QG
  bandwidth percent 24
  queue-limit percent 100
 class APP-3-QG
  bandwidth percent 12
  queue-limit percent 100
 class APP-4
  bandwidth percent 5
  queue-limit percent 100
 class class-default
  bandwidth percent 25
  queue-limit percent 100

class-map match-any APP-4-QG
 match qos-group 1
class-map match-any APP-3-QG
 match qos-group 2
class-map match-any APP-2-QG
 match qos-group 3
class-map match-any APP-1-QG
 match qos-group 4
class-map match-any REALTIME-QG
 match qos-group 5
class-map match-any NC-QG
 match qos-group 6
 match dscp cs6
 match dscp cs7

Now with all this configuration applied to the device it can be applied it to the interface:

PE2-ME3800#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
PE2-ME3800(config)#int gi0/10
PE2-ME3800(config-if)#service-policy output Gi0-10-SHAPE-OUT
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range
police burst (bc) is adjusted to 16000000 to fit the interface supported range

At this point Gi0/10 has 11x VLANs configured, each with its own EFP. The physical port has a parent policy applied which matches each of the 11 VLANs and creates the 11x 100Mbps shapers. The child policy sets up the individual traffic class queues, one of which is an LLQ with a 10% policer. The output of the command "show policy-map interface gi0/10 output" shows that everything is configured as it should be, no problems there, so not much to see. Everything so far has been fine but from here on the error occurs.

In the output below port 10 shows "total_class_bw_percent 990000". The child-policy for each port allocates 90% of the bandwidth for that VLAN (excluding the 10% LLQ policer) and since the parent policy creates a 100Mbps shaper this means each child-policy on each VLAN is creating 90Mbps of reserved bandwidth. 11x 90Mps = 990000Kbps. The "ref_count=10" shows a bandwidth element is applied ref_count+1 times as the counts starts from 0:

PE2-ME3800#show platform qos scheduler profile queue 0
Asic 0
1)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=20 mtu=1500 ! Gi0/24
2)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=0 mtu=1600 ! Gi0/1
3)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=0 mtu=1550 ! Gi0/23
4)PIR =1000000 bandwidth =20000 eir_ratio=1 ref_count=0 mtu=1550 ! gi0/23; class NC-QG; bandwidth percent 2
5)PIR =1000000 bandwidth =1000000 eir_ratio=1 ref_count=0 mtu=1550 ! Gi0/23; class REALTIME-QG; police cir percent 10
6)PIR =1000000 bandwidth =220000 eir_ratio=1 ref_count=0 mtu=1550  ! Gi0/23; class APP-1-QG; bandwidth percent 22
7)PIR =1000000 bandwidth =240000 eir_ratio=1 ref_count=0 mtu=1550  ! Gi0/23; class APP-2-QG; bandwidth percent 24
8)PIR =1000000 bandwidth =120000 eir_ratio=1 ref_count=0 mtu=1550  ! Gi0/23; class APP-3-QG; bandwidth percent 12
9)PIR =1000000 bandwidth =50000 eir_ratio=1 ref_count=0 mtu=1550  ! Gi0/23; class APP-4-QG; bandwidth percent 5
10)PIR =1000000 bandwidth =250000 eir_ratio=1 ref_count=0 mtu=1550  ! Gi0/23; class-default; bandwidth percent 25
11)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=0 mtu=1530 ! Gi0/10
12)PIR =100000 bandwidth =2000 eir_ratio=1 ref_count=10 mtu=1530 ! gi0/10; class NC-QG; bandwidth percent 2
13)PIR =100000 bandwidth =100000 eir_ratio=1 ref_count=10 mtu=1530 ! Gi0/10; class REALTIME-QG; police cir percent 10
14)PIR =100000 bandwidth =22000 eir_ratio=1 ref_count=10 mtu=1530  ! Gi0/10; class APP-1-QG; bandwidth percent 22
15)PIR =100000 bandwidth =24000 eir_ratio=1 ref_count=10 mtu=1530  ! Gi0/10; class APP-2-QG; bandwidth percent 24
16)PIR =100000 bandwidth =12000 eir_ratio=1 ref_count=10 mtu=1530  ! Gi0/10; class APP-3-QG; bandwidth percent 12
17)PIR =100000 bandwidth =5000 eir_ratio=1 ref_count=10 mtu=1530  ! Gi0/10; class APP-4-QG; bandwidth percent 5
18)PIR =100000 bandwidth =25000 eir_ratio=1 ref_count=10 mtu=1530  ! Gi0/10; class-default; bandwidth percent 25
port_num 10, total_class_bw_percent 990000
port_num 23, total_class_bw_percent 900000

Below a 12th VLAN is added to the carrier facing NNI:

int gi0/10
 service instance 12 ethernet
  description Cust12
  encapsulation dot1q 12
  rewrite ingress tag pop 1 symmetric
  bridge-domain 12
  exit
 exit

Next a 12th egress 100Mbps shaper is configured and the same child policy is applied:

class-map match-any CM-Cust12
match service instance ethernet 12
exit

policy-map Gi0-10-CUST-SHAPE
 class CM-Cust12
  shape average 100m
  service-policy PE-QOS-CUSTOMER-OUT
  exit
 exit

PE2-ME3800(config)#policy-map Gi0-10-CUST-SHAPE
PE2-ME3800(config-pmap)# class CM-Cust12
PE2-ME3800(config-pmap-c)#  shape average 100m
PE2-ME3800(config-pmap-c)#  service-policy PE-QOS-CUSTOMER-OUT
QoS:Bandwidth oversubscribed in the interface
QoS: Policy attachment failed for policymap PE-QOS-CUSTOMER-OUT
% service-policy PE-QOS-CUSTOMER-OUT of type default is not allowed in policy-map Gi0-10-CUST-SHAPE of type default
%QOSMGR-3-BANDWIDTH_OVERSUBSCRIBED: Bandwidth oversubscribed in the interface
]

That has failed. The child-policy applied to all the VLANs has already created 990Mbps of total aggregate bandwidth reservations across that port, trying to add a 12th set of child-policies (and thus bandwidth reservations) to that 12th VLAN shaper would push the total aggregate value of reserved bandwith on the 1Gbps port to over 1Gbps (12x 90Mbps = 1080Mbps). If that 12th VLAN is shaped down to just 10Mbps, the child policy would request 9Mbps of reserved bandwidth and that does work:

PE2-ME3800(config)#policy-map Gi0-10-CUST-SHAPE
PE2-ME3800(config-pmap)# class CM-Cust12
PE2-ME3800(config-pmap-c)#shape average 10m
PE2-ME3800(config-pmap-c)#service-policy PE-QOS-CUSTOMER-OUT
police burst (bc) is adjusted to 16000000 to fit the interface supported range
PE2-ME3800(config-pmap-c)#

PE2-ME3800(config-pmap-c)#$scheduler profile queue 0 | i port_num 10
port_num 10, total_class_bw_percent 999000

That took the total aggregate reserved bandwidth value on the port to 999Mbps.

PE2-ME3800(config-pmap-c)#shape average 11m
PE2-ME3800(config-pmap-c)#  service-policy PE-QOS-CUSTOMER-OUT
police burst (bc) is adjusted to 16000000 to fit the interface supported range
PE2-ME3800(config-pmap-c)#$scheduler profile queue 0 | i port_num 10
port_num 10, total_class_bw_percent 999900

! 999.9Mbps reserved ^ 

PE2-ME3800#show platform qos scheduler resource-usage
ASIC : 0
NETWORK Sub-Channels mapped to 4-Queue block :
        Starting Queue=0, Ending Queue=4095 Starting Sub-Channel=0, Ending Sub-Channel=1023
        Total effective Sub-channels=1024, Used Sub-Channel Count=25
NETWORK Sub-Channels mapped to 8-Queue block :
        Starting Queue=4096, Ending Queue=8191 Starting Sub-Channel=1024, Ending Sub-Channel=2047
        Total effective Sub-channels=512, Used Sub-Channel Count=13
CPU-RX Sub-Channels mapped to 4-Queue block :
        Starting Queue=0, Ending Queue=4095 Starting Sub-Channel=0, Ending Sub-Channel=1023
        Total effective Sub-channels=1024, Used Sub-Channel Count=25
PRIORITY TX Sub-Channels mapped to 4-Queue block :
        Starting Queue=0, Ending Queue=4095 Starting Sub-Channel=0, Ending Sub-Channel=1023
        Total effective Sub-channels=1024, Used Sub-Channel Count=25

Number of Queues (Class Level Resources) still available for Configurations = 7988
Number of Sub-Channels (Logical Level Resources) still available for Configurations
(assuming all are mapped to 4-queue blocks)= 1997

Used Queue Profile count : 25 of the total available 256
Used Sub-Channel Profile count : 6 of the total available 256
Used Channel Profile count : 54 of the total available 256

ASIC : 1
NETWORK Sub-Channels mapped to 4-Queue block :
        Starting Queue=0, Ending Queue=4095 Starting Sub-Channel=0, Ending Sub-Channel=1023
        Total effective Sub-channels=1024, Used Sub-Channel Count=3
NETWORK Sub-Channels mapped to 8-Queue block :
        Starting Queue=4096, Ending Queue=8191 Starting Sub-Channel=1024, Ending Sub-Channel=2047
        Total effective Sub-channels=512, Used Sub-Channel Count=0
CPU-RX Sub-Channels mapped to 4-Queue block :
        Starting Queue=0, Ending Queue=4095 Starting Sub-Channel=0, Ending Sub-Channel=1023
        Total effective Sub-channels=1024, Used Sub-Channel Count=3
PRIORITY TX Sub-Channels mapped to 4-Queue block :
        Starting Queue=0, Ending Queue=4095 Starting Sub-Channel=0, Ending Sub-Channel=1023
        Total effective Sub-channels=1024, Used Sub-Channel Count=3

Number of Queues (Class Level Resources) still available for Configurations = 8180
Number of Sub-Channels (Logical Level Resources) still available for Configurations
(assuming all are mapped to 4-queue blocks)= 2045

Used Queue Profile count : 2 of the total available 256
Used Sub-Channel Profile count : 2 of the total available 256
Used Channel Profile count : 33 of the total available 256



PE2-ME3800#show platform tcam utilization qos det
Nile Tcam Utilization per Application & Region:
ES == Entry size == Number of 80 bit TCAM words
==================================================================
App/Region            Start  Num Avail  ES    Used Range  Num Used
==================================================================
QOS                   57344     16384   2
    nile0                                                      514
    nile1                                                       81
------------------------------------------------------------------


PE2-ME3800#show platform tcam utilization eqos detail
Nile Tcam Utilization per Application & Region:
ES == Entry size == Number of 80 bit TCAM words
==================================================================
App/Region            Start  Num Avail  ES    Used Range  Num Used
==================================================================
EQOS                      0     16384   1
    nile0                                                       84
    nile1                                                       84
  EQOS_CONTROL        flags 0x19
     nile0               0        54   1       0-    53      54
     nile1               0        54   1       0-    53      54
  EQOS_USER           flags 0x1E
     nile0              54     16218   1  xxxxxx-xxxxxx       0
     nile1              54     16218   1  xxxxxx-xxxxxx       0
  EQOS_DEFAULT        flags 0x19
     nile0           16272        56   1  xxxxxx-xxxxxx       0
     nile1           16272        56   1  xxxxxx-xxxxxx       0
  EQOS_DEFAULT2       flags 0x19
     nile0           16328        54   1   16328- 16356      29
     nile1           16328        54   1   16328- 16356      29
  EQOS_CATCHALL       flags 0x19
     nile0           16382         2   1   16382- 16382       1
     nile1           16382         2   1   16382- 16382       1
------------------------------------------------------------------

 

Oversubscribing Egress Policers and Shapers

Using the same topology as above; a 1Gbps Ethernet NNI/aggregation port with 11 VLANs each of which are shaped to 100Mbps then it is possible to oversubscribe shapers at the logical level (remember the 3 level ME3600/ME3800 shaper paradigm, port - logical - class !).

If the original child-policy is re-written to use shapers instead of the "bandwidth" or" bandwidth remaining" commands for each class and applied, it can be seen that shapers can be used in an oversubscribed configuration where the total aggregate reservation for the shapers is 100% of the parent (so each 100Mbps shaped VLAN has 100Mbps of child shapers configured) but 11x 100Mbps VLANs with 100% total aggregate shapers are configured then 1,100Mbps of shapers are configured on this 1Gbps port:

policy-map PE-QOS-CUSTOMER-OUT-SHAPERS
 class NC-QG
  shape average percent 2
  queue-limit percent 100
  exit
 class REALTIME-QG
  shape average percent 10
  queue-limit percent 100
  exit
 class APP-1-QG
  shape average percent 22
  queue-limit percent 100
   exit
 class APP-2-QG
  shape average percent 24
  queue-limit percent 100
  exit
 class APP-3-QG
  shape average percent 12
  queue-limit percent 100
   exit
 class APP-4-QG
  shape average percent 5
  queue-limit percent 100
  exit
 class class-default
  shape average percent 25
  queue-limit percent 100
  exit


policy-map Gi0-10-CUST-SHAPRERS
class CM-Cust1
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust2
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust3
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust4
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust5
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust6
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust7
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust8
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust9
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust10
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS
class CM-Cust11
shape average 100000000
service-policy PE-QOS-CUSTOMER-OUT-SHAPERS

PE2-ME3800#show platform qos scheduler profile queue 0 Asic 0 1)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=22 mtu=1500 2)PIR =2000 bandwidth =0 eir_ratio=1 ref_count=10 mtu=1530 3)PIR =10000 bandwidth =0 eir_ratio=1 ref_count=10 mtu=1530 4)PIR =22000 bandwidth =0 eir_ratio=1 ref_count=10 mtu=1530 5)PIR =24000 bandwidth =0 eir_ratio=1 ref_count=10 mtu=1530 6)PIR =12000 bandwidth =0 eir_ratio=1 ref_count=10 mtu=1530 7)PIR =5000 bandwidth =0 eir_ratio=1 ref_count=10 mtu=1530 8)PIR =25000 bandwidth =0 eir_ratio=1 ref_count=10 mtu=1530 26)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=1 mtu=1530

Note that from the output above the "port_num 10, total_class_bw_percent" value is gone, even though we can see ref_count = 10 for each class on Gi0/10 (so 11 instances since it counts up from 0) there is no guaranteed bandwidth reservations being made on limitations.

If the child-policy is replaced with the same 7 class design but using policers for all classes the exact same behaviour is seen. The total aggregate bandwidth for a single VLAN is 100% (of the 100Mbps VLAN logical shaper) but 11 (or more) 100Mbps shaped VLANs can be configured each with 100% of their bandwidth allocated to class level policers and the "show platform qos scheduler profile queue 0" command shows no "port_num 10, total_class_bw_percent" value.

 

Oversubscribing Ingress Policers

Ingress policers can be oversubscribed in exactly the same way:


policy-map PE-QOS-CUSTOMER-IN-POLICERS
 class NC
  police cir percent 2
   conform-action transmit
   exceed-action drop
   exit
  ! queue-limit percent 100  ! queue-limit not allowed without bandwidth shape or priority command
  exit
 class REALTIME
  police cir percent 10
   conform-action transmit
   exceed-action drop
   exit
  ! priority ! Not supported on input queues
  ! queue-limit percent 100 ! queue-limit not allowed without bandwidth shape or priority command
  exit
 class APP-1
  police cir percent 22
   conform-action transmit
   exceed-action drop
   exit
   exit
 class APP-2
  police cir percent 24
   conform-action transmit
   exceed-action drop
   exit
  exit
 class APP-3
  police cir percent 12
   conform-action transmit
   exceed-action drop
   exit
 class APP-4
  police cir percent 5
   conform-action transmit
   exceed-action drop
   exit
  exit
 class class-default
  police cir percent 25
   conform-action transmit
   exceed-action drop
   exit
  exit


policy-map Gi0-10-CUST-IN-POLICERS
 class CM-Cust1
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
 class CM-Cust2
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust3
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust4
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust5
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust6
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust7
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust8
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust9
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust10
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust11
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
  class CM-Cust12
  police cir 100000000 pir 100000000 conform-action transmit  exceed-action drop  violate-action drop
   exit
  service-policy PE-QOS-CUSTOMER-IN-POLICERS
  exit
 exit

int gi0/10
no service-policy output PE-QOS-CUSTOMER-OUT-SHAPERS
service-policy input Gi0-10-CUST-IN-POLICERS

PE2-ME3800#show platform qos scheduler profile queue 0
Asic 0
1)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=22 mtu=1500
26)PIR =1000000 bandwidth =0 eir_ratio=1 ref_count=0 mtu=1530