Date created: Wednesday, October 31, 2012 12:24:32 PM. Last modified: Tuesday, November 15, 2016 12:05:04 PM

Shape Traffic Towards CPE

Shape traffic to downstream CPEs and prioritise VoIP traffic

class-map match-any VOICE
  match access-group 1
!
policy-map SHAPE-VOICE
  class VOICE
    priority 1500
policy-map SHAPE-5MBIT
  class class-default
    shape average 4900000
   service-policy SHAPE-VOICE
policy-map SHAPE-10MBIT
  class class-default
    shape average 9900000
   service-policy SHAPE-VOICE
!
! Interface facing CPE
!
interface GigabitEthernet0/0.10
 description 10Mbps CPE
 service-policy output SHAPE-10MBIT
!
access-list 1 remark VoIP-Servers
access-list 1 permit udp host 10.0.0.1 any
access-list 1 permit udp host 10.0.0.2 any