Date created: Sunday, June 21, 2015 7:57:11 PM. Last modified: Wednesday, March 28, 2018 5:11:31 PM

LAC L2TP Forwarding (Static & Dynamic)

Exampe 1: This example is for a dual LNS and LAC device, in this case some domains for the LAC feature are hard coded but RADIUS could also be used to return dynamic tunnel end points per domain too:

vpdn multihop
vpdn enable
vpdn ip udp ignore checksum
vpdn search-order domain multihop-hostname

vpdn-group 1
 description Accept incoming L2TP from another LAC/LTS
 accept-dialin
  protocol l2tp
  virtual-template 1
 source-ip 1.1.1.1
 local name lac-1
 lcp renegotiation on-mismatch
 l2tp tunnel password 123abc

vpdn-group 2
 description Forward static domains to another LNS
 request-dialin
 protocol l2tp
 domain resellerdomain.com
 domain anotherresellerdomain.com
 initiate-to ip 2.2.2.2
 source-ip 1.1.1.1
 local name lns-1
 l2tp tunnel password 123abc

Example 2: Load balancing all incoming PPPoE sessions over two LNS's (without RADIUS)

! LAC:
vpdn enable
vpdn multihop
vpdn search-order domain

vpdn-group test
 request-dialin
  protocol l2tp
  domain example.net
 ! Load balance to two difference LNS routers
 initiate-to ip 192.0.2.1
 initiate-to ip 192.0.2.5
 local name l2tp-tunnel
 no l2tp tunnel authentication

bba-group pppoe global
 virtual-template 1

interface FastEthernet1/0
 description Link to CPE
 no ip address
 pppoe enable group global

interface Virtual-Template1
 no ip address
 no ip redirects
 no ip proxy-arp
 no logging event link-status
 no peer default ip address
 ntp disable
 no keepalive
 ppp authentication pap callin

! LNS:
aaa new-model
aaa authentication ppp default local

ip domain name example.net

vpdn enable

vpdn-group test
 accept-dialin
  protocol l2tp
  virtual-template 1
 terminate-from hostname l2tp-tunnel
 local name tunnel-gw
 no l2tp tunnel authentication

username test@example.net password 0 testpassword

bba-group pppoe global
 virtual-template 1

interface FastEthernet0/0
 description Link to LAC
 ip address 192.0.2.1 255.255.255.252

interface Virtual-Template1
 ip vrf forwarding GRE
 ip unnumbered Loopback50
 no ip redirects
 no ip proxy-arp
 peer default ip address dhcp-pool test-pool
 ppp authentication chap pap